0

I'm trying to set up Samba on my Pi so that I can access files through my PC and analyze them. I followed the instructions here to set it all up, and it worked all fine until this last section:

From now on, Samba will start automatically whenever you power on your Pi. Once you’ve made sure that you can locate your shared folder on the network, you can safely disconnect the mouse, monitor, and keyboard from your Pi and just leave it running as a headless file server.

Find your Pi on the network

You’ll now be able to find your Raspberry Pi file server (named RASPBERRYPI by default) from any device on your local network. If you’ve left smb.conf’s default settings as they are, it will appear in a Windows network workgroup called WORKGROUP.

From my PC, I can't find the Pi "on the network". I have no idea how I'm supposed to access it. I went into the workgroup and it is connected to WORKGROUP, but I have no idea where to go from there. How do I access the files in my raspberry pi through my PC now?

1
  1. Uncomment wins support = no, and edit wins support = yes
  2. Make sure avahi-daemon is running. This should allow you to see it.

Else, there may be router config problem.

  • Still doesn't work but: 1. changed it 2. huh, I looked up online where it should be (/etc/init) and there's no script called avahi-daemon. SHould I download it from somewhere? – NeonCop Jul 6 '17 at 22:37
  • try sudo service avahi-daemon status. If not there, then do apt-get install. – Sean Lee Jul 6 '17 at 22:58
  • It says it is active (running), but gives me 10 different lines at the end that say "invalid response packet from host (hostname here)" – NeonCop Jul 6 '17 at 23:05
  • That sounds like an old known bug in avahi. Are you using the latest noobs from raspberrypi download? Just a suggestion, if this continues to be a problem, perhaps consider using raspbians instead of noobs. – Sean Lee Jul 6 '17 at 23:18
  • I certainly think so, I downloaded it last Monday. The offline and network install version – NeonCop Jul 6 '17 at 23:19
0

Assuming you're on a Windows machine, try opening Start->Run and enter \\raspberrypi (or whatever you named your RPi) or enter that path in Explorer.

  • When I do that, it says Windows cannot access //raspberrypi (I didn't change the name). However, I'm not on a standard SSID/password network, I'm on a university's network, is there a chance that could be preventing the two from talking to each other? I was thinking even though they are on the same wi-fi they might not be connected to the same router since there's probably like a million of those around. – NeonCop Jul 6 '17 at 22:40
  • is your hostname raspberrypi? If you are on University network, then you are subject to their routing and net sharing rules. Why don't you get a simple router and try isolated environment with pi and pc to see if you can each other? – Sean Lee Jul 6 '17 at 22:56
  • Did you use backquotes (\) or forward quotes (//)? Need to be backquotes. – bobstro Jul 6 '17 at 23:09
  • @SeanLee that's a great idea, I'l take my Pi home to see if the problem is with the Pi or the network. – NeonCop Jul 6 '17 at 23:10
  • @bobstro I used backquotes... I'm thinking it probably isn't a problem with my PC and probably something to do with the Pi – NeonCop Jul 6 '17 at 23:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.