I follow this tutorial to be able to setup static IP address on WiFi connection, in particular, after change /etc/network/interfaces file I do this two commands

sudo systemctl disable dhcpcd
sudo systemctl enable networking

after that I am not be able to connect on WiFi but I am able to connect via wired LAN.


On network icon I can see tho errors:

eth0: Link is down
wlan0: Not associated


No wireless interfaces found

below my /etc/dhcpcd.conf file:

A sample configuration for dhcpcd.
# See dhcpcd.conf(5) for details.

# Allow users of this group to interact with dhcpcd via the control socket.
#controlgroup wheel

# Inform the DHCP server of our hostname for DDNS.

# Use the hardware address of the interface for the Client ID.
# or
# Use the same DUID + IAID as set in DHCPv6 for DHCPv4 ClientID as per RFC4361.

# Persist interface configuration when dhcpcd exits.

# Rapid commit support.
# Safe to enable by default because it requires the equivalent option set
# on the server to actually work.
option rapid_commit

# A list of options to request from the DHCP server.
option domain_name_servers, domain_name, domain_search, host_name
option classless_static_routes
# Most distributions have NTP support.
option ntp_servers
# Respect the network MTU.
# Some interface drivers reset when changing the MTU so disabled by default.
#option interface_mtu

# A ServerID is required by RFC2131.
require dhcp_server_identifier

# Generate Stable Private IPv6 Addresses instead of hardware based ones
slaac private

# A hook script is provided to lookup the hostname if not set by the DHCP
# server, but it should not be run by default.
nohook lookup-hostname

I change also /etc/network/interfaces

# interfaces(5) file used by ifup(8) and ifdown(8)

# Please note that this file is written to be used with dhcpcd
# For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'

# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

auto lo
iface lo inet loopback

iface eth0 inet manual

allow-hotplug wlan0
iface wlan0 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

allow-hotplug wlan1
iface wlan1 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

Of course I reset hdcpcd on running these commands:

sudo systemctl disable networking
sudo systemctl enable dhcpcd

But the status is as described before: cunenction with DHCP on wired and no connection with WiFi.

I want to reset all and after set Static IP address on WiFi connection

If I run systemctl status dhcpcd.service when connected to wired network:

dhcpcd.service - dhcpcd on all interfaces
   Loaded: loaded (/lib/systemd/system/dhcpcd.service; enabled)
  Drop-In: /etc/systemd/system/dhcpcd.service.d
   Active: active (running) since gio 2017-07-06 18:08:17 CEST; 16h ago
 Main PID: 645 (dhcpcd)
   CGroup: /system.slice/dhcpcd.service
           └─645 /sbin/dhcpcd -q -w

If I do it when I am without LAN cable and restart:

dhcpcd.service - dhcpcd on all interfaces
   Loaded: loaded (/lib/systemd/system/dhcpcd.service; enabled)
  Drop-In: /etc/systemd/system/dhcpcd.service.d
   Active: active (running) since ven 2017-07-07 10:55:27 CEST; 53s ago
  Process: 382 ExecStart=/sbin/dhcpcd -q -w (code=exited, status=0/SUCCESS)
 Main PID: 645 (dhcpcd)
   CGroup: /system.slice/dhcpcd.service
           └─645 /sbin/dhcpcd -q -w
Warning: Unit file changed on disk, 'systemctl daemon-reload' recommended.

With another installation of the same OS, I have the second result but here WiFi works.

  • I see no attempt to set static IP addresses. You have to EITHER use dhcpcd OR Debian networking. If you use the latter the GUI Network icon will not work (as it relies on dhcpcd). I still fail to understand WHY – Milliways Jul 7 '17 at 8:40
  • Yep, I try to setup static IP with debian networking, but when I see the error in icon and no connection, I try to reset all things back, now with this configuratin WiFi doesn't working anymore. – Francesco Gusmeroli Jul 7 '17 at 8:43
  • What does systemctl status dhcpcd.service show? DO NOT post into Comments, edit your question. – Milliways Jul 7 '17 at 8:47
  • Ok perfect, I can see some differences with cable and without – Francesco Gusmeroli Jul 7 '17 at 9:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.