0

So I am currently trying to set up some peripherals on my RPI3, and I have run into some issues. On my first run through I tried to install the Audio Out via a bluetooth speaker only to find out that my speaker is trashed. I re-installed Raspbian and now I am trying to get Audio In through a USB Microphone and Audio Out through a pair of headphones.

The first thing that I tested with the fresh install was the headphones, popped them in switched the sound from HDMI to Analog and it worked like a charm. I plugged in the USB mic and got it to show up on alsamixer but whenever I did arecord test.wav I got thrown an error about it not having an input, I did some magic to the /usr/share/alsa/alsa.conf and changed

defaults.ctl.card 0 >>> defaults.ctl.card 1 defaults.pcm.card 0 >>> defaults.pcm.card 1

and I also created ~/.asoundrc with

`pcm.!default {
    type plug slave {pcm "hw:1,0"}
}

ctl.!default{
    type hw
    card 1
}

After I did this it seems to work when I record Audio as the file size looks to be of decent size when using USB microphone but it isn't playing back VIA Analog or HDMI (I also tested to see any sound VIA youtube video).

What I think is happening is that I set USB as Audio IN and OUT whereas I only want it as in.

TL;DR Is there a way to have Audio Input as a USB Microphone and Audio Output through 3.5 Jack/HDMI

Thank you!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.