0

As I unsuccessfully tried to connect my Pi to a new wifi network at work I kind of blow up the "original setting" and i'm however still unable to connect to internet using my pi. I had the situation where i was able to ping 8.8.8.8 but couldn't load google.com Here are the content of my etc/network/interfaces

auto lo
iface lo inet loopback
iface eth0 inet static 
    address 10.93.128.114
    netmask 255.255.255.0
    network 10.93.128.0
    broadcast 10.93.128.255
    gateway 10.93.128.254

and /etc/dhcpcd.conf

interface eth0
static ip_address=10.93.128.114/24
static routers=
static domain_name_servers=    
static domain_search=

route -v :

destination -> 10.93.128.0 
gateway -> *
genmask -> 255.255.255.0

ifconfig :

inet addr:10.93.128.114 Bcast:10.93.128.255 Mask:255.255.255.0
0

Try to reset etc/network/interfaces like original, replace what you have written in this fali with that:

auto lo
iface lo inet loopback
iface eth0 inet manual

and also /etc/dhcpcd.conf deleting all things regarding eth0, basically delete what you have write in your answer

If you want to fix tour configuration, on /etc/dhcpcd.conf you can try to add

static domain_name_servers=8.8.8.8

because in your configuration there is no DNS

  • This bears NO resemblance to "original" – Milliways Jul 10 '17 at 11:24
  • 1
    Replacing his etc/network/interfaces rows and deleting all things he wrote on /etc/dhcpcd.conf these files are like original one, also I think the problem is on the domain_name_servers without value – Francesco Gusmeroli Jul 10 '17 at 12:42
  • you were right i just got the right DNS at work today and everything worked fine thx again for help :) – Wizkhas Jul 11 '17 at 12:33
  • @Wizkhas if it is the correct answer, you can accept it so your question is marked answered – Francesco Gusmeroli Jul 11 '17 at 12:43
  • forgot to do so, thx for reminding me – Wizkhas Jul 11 '17 at 14:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.