1

Simple question: how do you turn off the d*mn screen saver in Raspbian for Pi 3 Model B? It keeps popping up even if I leave Chromium looping a video in Kiosk mode. I tried the solution from this answer, but it does nothing to stop the screensaver from showing.

3

You should try using xscreensaver. You can easily disable screen saver using xscreensaver-demo, which will prompt a simple GUI config. In the Display Modes tab, you should see a drop-down list named Mode. From there select Disable Screen Saver and that should do the trick.

You don't have to use the graphical interface, here is a link to the manual if you are interested in looking at specific terminal commands etc: https://www.jwz.org/xscreensaver/man1.html

  • This disabled the screensaver, but the screen still turned to black. – Daniel Harris Jul 10 '17 at 18:29
  • You should check the Advanced tab and look for Display Power Management. I think you want to deselect both Power Management Enabled and Quick Power-off in Blank Mode. – LecauseAndThePi Jul 11 '17 at 8:42
  • I have spent countless evenings scouring the Internet for a solution to the blank screen problem, none work. This finally does (FWIW, Pi 3, Raspbian GNU/Linux 9.3 (stretch) Raspberry Pi reference 2017-11-29) – smirkingman Feb 9 '18 at 21:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.