1

For the last week I've had trouble powering up my new Pi. Initially I tried booting Raspbian while powering the board using a USB cable, but the activity light would not flash at all. I then tried with another USB cable, same issue.

At that point I put NOOBS on my SD card because I figured something went wrong when I tried to dump Raspbian onto it. However, the problem persisted. I took some measurements and found that I was only getting at most 8 mV running through the two USB cables.

After that, I connected my Pi to a powered breadboard I own via the header pins and set its voltage output to 5V. I verified with my multimeter that 5V was running to my Pi through the 5V+ and GND pins. Still no activity took place.

I tried a few more times to load different images on the card just to verify it wasn't a software issue, but nothing helped. I'm using an SD card that should be compatible with the Pi, a SanDisk Ultra SDHC 32GB.

While I understand each Pi is tested before it leaves the manufacturing facility, I'm led to believe I may have a dead or damaged Pi Zero. In spite of all this however, it does register as a USB device whenever I connect it to my computer, which is holding me back from being absolutely sure it's a dud.

Is there anything I'm missing that could explain why my Pi isn't working? Any help/suggestions would be appreciated.

  • Did you try another mSD card to make sure it's not an individual mSD card problem? As for 8mV ... did you mean 8mA, per chance? – TheDiveO Jul 10 '17 at 16:49
  • Nope, I did mean 8 mV. But hey, you fixed my problem! It boots now. That's odd, I read that SanDisk Ultra was a supported card. – Michael Lilley Jul 10 '17 at 21:34
  • Looks like you don't get the "rip" tag for this one...! 8-) – SlySven Jul 11 '17 at 15:20
2

Sometimes individual cards are bad, for whatever reason. Or a certain batch doesn't work sufficiently. So having another mSD card (and type) ready helps in sorting out whether the mSD card is the culprit, or the Raspberry Pi. The former seems to be more often causes for problems, while the Pis seem to be much more robust than mSD cards.

0

There is always the possibility of having a bad SanDisk card, and an even greater chance of a COUNTERFEIT one, especially at a "too good to be true" price from a foreign vendor on eBay.

0

simply extract sd carde remove all connections apply power from usb cable and test from ground to pin 2, 4 must be 5 volts; pin 1 must be 3.3 volts.if not put the pi zero in your basket! RIP

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.