1

I created a backup file in Raspbian [on my Raspberry 2 Model B] which sits in the /home directory. I want to copy it to my USB stick to the /media/pi directory. The stick is formatted for EXT4. My Raspbian /root is also EXT4.

I tried using the File Manager to copy and paste but got a "Error opening file /mnt/pi/filename.tar.gz:Permission denied" message. I also ran cp from the terminal window and got the message "cp cannot create regular file '/media/pi/filename.tar.gz' : Permission denied". Here's that cp entry:

cp filename.tar.gz /media/pi

Clues would be greatly appreciated. Thank you very much ... Bill Cole

1

You may want to check the owner and access rights with which your ext4 partition has been mounted. A quick solution may be to use sudo cp filename.tar.gz /media/pi to copy your archive file to your USB partition.

2
  • Thank you very much for the advice. Worked just fine. Very kind of you to take the time to reply to my question.
    – wacole
    Jul 12 '17 at 19:14
  • You're welcome. If this solves your problem, then please accept this answet; click on the checkmark/tick.
    – TheDiveO
    Jul 12 '17 at 20:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.