1

I want to configure a Samba share with guest read and write access. Here is my smb.conf file :

[global]
workgroup = WORKGROUP
server string = Rpi Samba Server
security = user

[nas]
path = /media/nas
browseable = yes
read only = no
guest ok = yes
force user = pi
locking = no
writable = yes

The shared folder has the following permissions :

drwxr-xr-x 4 pi users 4096 Apr 11 21:16 nas

There is nothing complicated with this config. The Samba daemon is using the pi user (who has correct UNIX file permissions) to write to the directory. It used to work fine using the Raspbian distro. However, when I want to create a folder or a file inside the share using my file manager (Thunar), it seems I don't have write access. The smbd.log outputs this :

[2013/04/11 21:28:27.391104,  0] smbd/trans2.c:1253(unix_filetype)
unix_filetype: unknown filetype 0

Anyone help ?

  • serverfault.com/questions/31298/… is this related? – Max Apr 12 '13 at 12:14
  • @mishka this doesn't belong here, try questions related to samba on serverfault.com – 1ac0 May 13 '13 at 10:36
  • @LadislavDANKO This question is actually perfectly fine. Any question related to the Raspberry Pi is on topic in accordance with the faq. Mainly because we don't like to migrate questions needlessly. – user46 May 13 '13 at 21:11
1

Global directive guest account resolved the issue. It tells Samba which UNIX user to use to access the file system.

So my config is like this :

[global]
workgroup = WORKGROUP
server string = Rpi Samba Server
security = user
guest account = pi

[nas]
comment = Serveur NAS
path = /media/nas
browseable = yes
read only = no
guest ok = yes
writable = yes

Unfortunatly this parameter is not available per share.

Glad if it helps

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.