0

I have a talktalk router with two ethernet ports and wifi. I have decided to setup a raspberry pi as a dhcp server and to turn off the dhcp server in the router. The raspberry pi is connected physically to one of the ethernet ports.

I set it all up and turned off the dhcp on the router but none of my wireless devices got any dhcp response. I thought I had made a mistake configuring it but when I checked a device plugged into the ethernet port I found that it sucessfully got a lease. (I checked the raspberry pi leases file and my network hard disk had a lease assigned.)

So it seems the wireless dosen't get the dhcp but the ethernet ports do. Does anyone know if there is any functionality on the talk talk router that isolates ethernet from wireless?

My router is a Huawei HG523a There is an option under Basic -> WLAN called "AP isolation:" this is not ticked

  • This page shows others are having similar problems: community.talktalk.co.uk/t5/Computers/DHCP-issues-with-HG523a/… this might not be possible on my router :( – Robert3452 Jul 12 '17 at 19:21
  • 1
    WHY???????* – Milliways Jul 12 '17 at 23:58
  • I have many devices on my home network and normally I configure then fixed ips on the router and manually add entries into lots of hosts files. As I add and remove devices the overhead is high and host files are mostly out of date. I have created an ansible routine to maintain a dhcp and DNS server based on a pi and this will be much easier to maintain. – Robert3452 Jul 13 '17 at 5:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.