0

I'm currently sharing my Internet connection with my laptop to my Raspberry Pi 3 via an Ethernet cable. When I entered the hostname -i command in the terminal, an IP address starting with 169 is returned and pinging any website doesn't work. From what I've read, this means that the computer wasn't able to talk to a DHCP server and the only way to fix this is to reboot the router. Unfortunately, I'm currently at a university and have no way to reboot the router.

Is there any way to reconfigure the Internet settings so that it works?

  • Rebooting the router under most circumstances isn't the solution, but just another way to say "don't bother me, go away" or "I don't know". – TheDiveO Jul 13 '17 at 7:51
2

169 is a Link-local address.

If you have DIRECTLY connected to your PC there is NO network connection. You can talk to the PC (and vice versa).

You CAN enable ICS which SHOULD provide an IP address, but this is a Windows question.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.