1

I know it is not the first time this question has been asked. However I was not able to get any previous solution to work, and trust me I've tried everything I could find.

When I first received my RPi and set it up at my apartment, everything worked great including the WiFi, now I'm setting it up at my parents place, and it simply wont connect via WiFi. I've made sure the password and ESSID match, that there is a strong signal when running iwlist scan wlan0 and that is is over all connected to the network, I can however only connect when I plug in ethernet. So I can SSH into the Pi just fine using the WiFi ip (i.e. the one I get from ifconfig wlan0) while the ethernet cable is plugged in, but if I unplug it the connection is lost, and I'm not able to reestablish it until I plug it back in.

A simple ping command to the Pi while unplugged yields either nothing, ping: sendto: No route to host or ping: sendto: Host is down.

Below I've added some images, that show my router WiFi settings, and it even shows that my Pi is connected to the router, I also included a screendump of the ifconfig command. I've literally tried everything I could find on the forums, even firmware upgrades and what not. Thanks in advance!

//Andreas

Image of Access Point settings Image of Pi on Access Point Image of ifconfig on Pi

  • What does ifconfig eth0 show? – anonymoose Jul 16 '17 at 0:48
  • @anonymoose ifconfig eth0 yields inet addr:10.0.0.18 Bcast:10.0.0.255 Mask:255.255.255.0 – user68902 Jul 16 '17 at 0:50
  • This might sound crazy, but you could try sudo ifdown wlan0 while logged in from wifi and see if your connection stays up. – anonymoose Jul 16 '17 at 0:51
  • I was thrown off after using that command, while connected via WiFi IP. packet_write_wait: Connection to 10.0.0.9 port 22: Broken pipe – user68902 Jul 16 '17 at 0:53
  • Do you have another way of connecting to the Pi such as a serial console or HDMI/keyboard? – anonymoose Jul 16 '17 at 0:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy