0

I get lines and lines of garbage when I try to look a my current fonts: !"#$%&'()*+,-./0123456789:;<=>?@

I've tried numerous setfont alternatives. They all give me various flavors of garbage characters. Also tried various "Localisation Options".

Anybody know what do I need to do to translate that into something that looks like some kind of standard ascii character set when I use the showconsolefont command?

1 Answer 1

1

Have you tried using sudo dpkg-reconfigure console-setup to select a font? Here's what my /etc/default/console-setup looks like using a 16x32 Terminus font that looks good on a large 1080p display:

ACTIVE_CONSOLES="/dev/tty[1-6]" CHARMAP="UTF-8"

CODESET="guess" FONTFACE="Terminus" FONTSIZE="16x32"

VIDEOMODE=

Using this configuration, showconsolefont displays as expected.

4
  • Your /etc/default/console-setup file looks exactly same as mine so thats not the issue. My text looks fine on the console, but when I telnet or ssh to a Linux server and run any utility that does upper ascii line drawing the boxes look like crap... garbage characters ... the reason I went to check my showconsolefont output. I figure if I can find the magic setting to clean up showconsolefont then I can probably get proper line drawing connecting to an outside server.
    – randytech
    Commented Jul 18, 2017 at 14:21
  • If you're connecting to your RPi via telnet or ssh, then you're seeing the fonts displayed by the terminal program on the computer that you're sitting at. You need to find a font for that program that will display the necessary character set. Note that showconsolefont probably won't work if using a terminal program. You can change your terminal fonts independently of the console fonts. They are not connected. If you can mention the program that's displaying the garbage characters, I can try with several terminal fonts that I've had good luck with.
    – bobstro
    Commented Jul 18, 2017 at 15:05
  • I don't think so. If I use putty for example, I can put in bad settings in putty and get garbage characters on the Linux server similar to what the PI gives me. That does not mean there is anything wrong on the Linux server. I can ssh from 100 other Linux computers (conservatively speaking) into this same Linux server that is giving me garbage on the PI. They all have clean drawing. Putty is clean. SecureCRT is clean. Only the PI gives garbage characters --AND-- only the PI gives me garbage with the showconsolefonts command --SO-- it has to be a bad setting in the PI.
    – randytech
    Commented Jul 18, 2017 at 19:19
  • No matter the consequence of telnet or ssh connection to the PI, that is totally irrelevant to the showconsolefonts on the PI giving me garbage, unlike all the other non-jessie Linux machines I've tested.
    – randytech
    Commented Jul 18, 2017 at 19:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.