0

I've just started using my RP3 as my development box, and got everything working fine: Python 3.6, created venv's, installed posgresql, working with Django. All is fine. Except that, if I want to work with Heroku, their CLI (former Toolbelt) won't install, stating the package doesn't exist.

What I did:

Their official site states that we should run a script:

wget -qO- https://cli-assets.heroku.com/install-ubuntu.sh | sh

Which basically seems to include heroku on the sources for apt-get, update it (apt-get update) and then install by running apt-get install heroku. Full output is here:

$ sudo wget -qO- https://cli-    assets.heroku.com/install-ubuntu.sh | sh
+ SUDO=
+ id -u
+ [ 1000 != 0 ]
+ SUDO=sudo
+ echo This script requires superuser access to install apt packages.
This script requires superuser access to install apt packages.
+ echo You will be prompted for your password by sudo.
You will be prompted for your password by sudo.
+ sudo -k
+ sudo sh
+ dpkg -s apt-transport-https
+ echo deb https://cli-assets.heroku.com/branches/stable/apt ./
+ dpkg -s heroku-toolbelt
+ true
+ apt-key add -
+ wget -qO- https://cli-assets.heroku.com/apt/release.key
OK
+ apt-get update
Get:1 http://mirrordirector.raspbian.org jessie InRelease [14.9 kB]
Hit https://cli-assets.heroku.com ./ InRelease
Hit https://cli-assets.heroku.com ./ Packages
Get:2 http://mirrordirector.raspbian.org jessie/main armhf Packages [9,533 kB]
Get:3 https://cli-assets.heroku.com ./ Translation-en_GB [364 B]
Hit http://archive.raspberrypi.org jessie InRelease
Get:4 https://cli-assets.heroku.com ./ Translation-en [361 B]
Hit http://archive.raspberrypi.org jessie/main armhf Packages
Get:5 https://cli-assets.heroku.com ./ Translation-en_GB [364 B]
Get:6 https://cli-assets.heroku.com ./ Translation-en [361 B]
Hit http://archive.raspberrypi.org jessie/ui armhf Packages
Get:7 https://cli-assets.heroku.com ./ Translation-en_GB [364 B]
Get:8 https://cli-assets.heroku.com ./ Translation-en [361 B]
Get:9 https://cli-assets.heroku.com ./ Translation-en_GB [364 B]
Get:10 https://cli-assets.heroku.com ./ Translation-en [361 B]
Get:11 https://cli-assets.heroku.com ./ Translation-en_GB [364 B]
Ign https://cli-assets.heroku.com ./ Translation-en_GB
Get:12 https://cli-assets.heroku.com ./ Translation-en [361 B]
Ign https://cli-assets.heroku.com ./ Translation-en
Get:13 http://mirrordirector.raspbian.org jessie/contrib armhf Packages [43.3     kB]
Get:14 http://mirrordirector.raspbian.org jessie/non-free armhf Packages [84.2     kB]
Get:15 http://mirrordirector.raspbian.org jessie/rpi armhf Packages [1,356 B]
Ign http://archive.raspberrypi.org jessie/main Translation-en_GB
Ign http://archive.raspberrypi.org jessie/main Translation-en
Ign http://archive.raspberrypi.org jessie/ui Translation-en_GB
Ign http://archive.raspberrypi.org jessie/ui Translation-en
Ign http://mirrordirector.raspbian.org jessie/contrib Translation-en_GB
Ign http://mirrordirector.raspbian.org jessie/contrib Translation-en
Ign http://mirrordirector.raspbian.org jessie/main Translation-en_GB
Ign http://mirrordirector.raspbian.org jessie/main Translation-en
Ign http://mirrordirector.raspbian.org jessie/non-free Translation-en_GB
Ign http://mirrordirector.raspbian.org jessie/non-free Translation-en
Ign http://mirrordirector.raspbian.org jessie/rpi Translation-en_GB
Ign http://mirrordirector.raspbian.org jessie/rpi Translation-en
Fetched 9,677 kB in 21s (450 kB/s)
Reading package lists... Done
+ apt-get install -y heroku
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package heroku

Installing what they call the "Standalone" program also doesn't seem it would work, since there are builds for x86 and x64 only, not ARM, which is the RPI's architecture.

Has anyone succeeded in doing this? I found other questions like this online, but no answer!

3
  • Why not ask this over on the Heroku site? Commented Jul 19, 2017 at 0:21
  • I did, no answer from them. It's a small app, still in testing, using only their free dynos - I guess support only cares about high-volume apps who pay for a lot of CPU and traffic. Commented Jul 19, 2017 at 11:39
  • For the record: I DID try the standalone but, as expected, it doesn't run on ARM Commented Jul 19, 2017 at 11:49

2 Answers 2

0

According to Heroku support, there's no official support at this time (July 2017) with snap being an option in the future. They claim some people manage to do it with npm, which I also tried without success.

Their response:

Hey Marcelo,

We're currently working on a cross-platform install method for the CLI with snap. I can let you know here when it's publicly available. Some folks have got the CLI to install on arm via npm but we don't officially support it. Snap should be a great solution for arm users when it's ready (snap will also show up here when public).

Thanks for reaching out!

1
  • Please accept your own answer with a click on the tick on its left side. Only this will finish the question and it will not pop up again year for year.
    – Ingo
    Commented Apr 10, 2020 at 10:08
0

@Marcelo You can actually install heroku with the Stand Alone procedure. ' I did and it worked for me. Also replace REPLACEME_OS-REPLACE_ME_ARCH with linux-arm

# replace REPLACE_ME_OS/REPLACE_ME_ARCH with values as noted below $ wget https://cli-assets.heroku.com/heroku-cli/channels/stable/heroku-cli-REPLACEME_OS-REPLACE_ME_ARCH.tar.gz -O heroku.tar.gz $ tar -xvzf heroku.tar.gz $ mkdir -p /usr/local/lib /usr/local/bin $ mv heroku-cli-v6.x.x-darwin-64 /usr/local/lib/heroku $ ln -s /usr/local/lib/heroku/bin/heroku /usr/local/bin/heroku

I also needed to refresh the link to: /usr/local/lib/heroku

instead of the old: /usr/local/heroku/bin/heroku

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.