I ordered a digital servo JX 5521MG to use with my Pi but when I use the code below the servo does not move but there is a slight tick or twitch inside.

gpio pwm-ms
gpio pwmc 192
gpio pwmr 2000

gpio -g pwm 18 100

I have successfully used the same code with a different model of servo the FS5103R so I am wondering if I have a faulty servo or whether I need to change the input code.

  • Does the same code still work with the other servo? What frequency and dutycycle do those commands actually produce? – joan Jul 19 '17 at 7:43
  • @joan Yes this still works with the other servo. I also used the following Python Script: pwm=GPIO.PWM(18,300) and pwm.start(32) but the servo just shudders back and forth, not moving the main gear. I have tried with two different power sources (5.0V 2.4A) with the same result. I am thinking the servo could be faulty? – alkey Jul 22 '17 at 9:33
  • Could it be that the servo is not able to draw enough current from the supply? The torque is around 20kg/cm3? – alkey Jul 22 '17 at 9:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.