8

I recently installed Debian 7.0 (Wheezy) on a 32 GB SD card, but so far the Raspberry Pi has not been able to boot. I replaced the elf, bin files, etc... and the monitor is now getting a response, but no boot up screen - it is just blank.

When I turn it on, a red light comes up, then a brief flash of green at the start and the process ends. I have tried using different cables and power supplies, but still nothing has been successful.

I'm using a 5 V 1 A power supply that according to reviews should work with the Raspberry Pi.

The only possible issue is that I'm using an SD card a mate gave to me. It's new, but I've never seen the brand before, and I believe that it's probably the reason behind the fault. I wrote Wheezy on to it using a built-in reader on my Packard Bell laptop which runs on Windows 7.

I have ordered a new SD card pre-loaded with wheezy and hoping this will do the trick, as I've heard that some built-in card readers are not good for writing boot up disks.

What is the solution to my problem?

  • Could you please specify how many green OK led flashes do you see? Is it only one or maybe there's more? The exact number is very important. Also, is this green led as bright as red led? – Krzysztof Adamski Apr 13 '13 at 13:53
  • How are you connecting to the monitor? Are you using VGA? – Eric Wilson Apr 14 '13 at 2:49
  • This issue was resolved for me by formatting my SD card and placing the raspberry pi image file back on the SD card. You may want to try a smaller card. The largest I've had luck with is 16GB on the original model. – earthmeLon May 20 '13 at 23:43
7

For a lot of newcomers the problem is not necessarily the SD card/installation, but rather the communication with your monitor (as Eric Wilson rightly asks above). Many people reuse an old(er) 'VGA' (or similar, SVGA, XVGA) monitor with the PC-style VGA connector, and then use an HDMI-to-VGA 'adaptor'. BUT there are 'issues' with this, that require you to edit your config.txt file to force the output into the correct format.

Of course I cannot be sure that this is your problem, which is why we need to know what kind of monitor you are using. Even so, call this an 'educated guess', but you need to search around for 'Raspberry Pi HDMI to VGA' where you will find tons of people with similar problems, and various solutions. This stumps a lot of people, and it really deserves something of a 'Health Warning' - monitors have different requirements and the settings take some getting used to.

Tip 1: if you need to edit that config.txt file, you'll almost certainly find it easier to do this back on your PC, editing directly from the SD card. HOWEVER you'll want to use a true plain text editor that will handle the line breaks properly, since Linux and Windows do this differently, ordinary Notepad can mess up your files, so you'll want to use a utility like 'Notepad++' which is downloadable on the web.

Tip 2: There's a discussion about this in a place you might not think to look - on Amazon where people are commenting about HDMI to VGA cables and providing some useful advice about Raspberry Pi settings, e.g. http://www.amazon.co.uk/gp/aw/review/B0088K7QUQ/RE81S534DQ1CR/ref=aw_cr_RD64E946QD7M8?cursor=3&sort=rd

Tip 3: There's a basic discussion about the HDMI to VGA problem here: http://www.raspberrypi.org/phpBB3/viewtopic.php?p=269212

and it includes the suggestion to edit the config.txt file and UN-COMMENT the second of the following two lines when you find them (i.e. REMOVE the '#' comment symbol as the first character), which will force the output to come out on most VGA monitors, albeit at a very 'expanded' size, 640x480, but at least it will get you going:

# uncomment if you get no picture on HDMI for a default "safe" mode
hdmi_safe=1

Tip 4: Here on stackexchange there's a more thorough discussion about the various monitor settings: https://raspberrypi.stackexchange.com/tags/config.txt/info

Tip 5: More great discussion, including how to find the relevant values for your monitor, on http://elinux.org/RPi_config.txt#Which_values_are_valid_for_my_monitor.3F

All the best - if I get some time I may try to provide a more user-friendly discussion of this headache.

Cheers, and let us know how it goes.

-Marc

  • Cheers for the advice guys, i connected to my tv now via HDMI still getting the single flash of green but now all im getting is multicoloured screen ? – Thomas Anthony Cuschieri Apr 14 '13 at 16:07
  • 1
    If this was the problem, wouldn't he see more than just one green flash? – Mike McKay May 10 '13 at 2:08
  • Regarding your Tip 1, I have found that you can use any text editor on Windows to edit config.txt, the RPi will tolerate CR LF line breaks in this file. EG, plain NotePad is okay, NotePad++ or others that keep just LF line endings aren't specifically needed. – Todd Jun 9 '13 at 3:02
1

I suggest to try a different (higher current) power supply (PSU). I found (oddly) the PSU supplied was not sufficient depending on if the monitor was connected or not.

I reinstalled NOOBS, and everything was OK.

0

I would try a fresh card and start with Raspbian “wheezy” from http://www.raspberrypi.org/downloads

0

You may want to check out the following article (item 2 in particular about monitors): Raspberry Pi 'Gothcas' and new buyer tips

0

I had the exact same problem - just a single green flash and then nothing except the power light. This happened with two different distributions that I tried. Then I read that newer versions of the Pi - the one with double the RAM - were not working with some images. So I got the latest from here: http://www.raspberrypi.org/downloads and it worked. Hope that helps.

0

That's what my Raspberry Pi is doing, only mine doesn't show green, it just shows red. All I can suggest is using NOOBS instead.

0

If the green LED flashed, there's no problem with connecting to the SD card.

Did you connect the monitor and powered it on before the Raspberry Pi is powered on? Raspberry Pi doesn't support HDMI hot-plugging. So if you connect or power on the monitor after Raspberry Pi power is on, you will see a black screen.

0

Open the content of the SD card on your computer and look for the file config.txt. Edit that file and comment out all lines, that don't contain a # already at the start.

This will cause Ubuntu to use only the defualt settings for everything.

Put the SD card in your Pi and enjoy ;)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.