0

So I have the adafruit GPS attached to a pi zero W via UART

cat sudo cat /dev/ttyS0 will get me data $GPGSA,A,3,05,29,25,21,20,,,,,,,,2.46,2.27,0.95*01 7,81.8,M,47.6,M,,*4C $GPRMC,111257.000,A,5101.5679,N,00123.8599,W c.42,133.72,210717,,,A*78

As will sudo gpsmon /dev/ttyS0

BUT cgps -s fails and so does the adafruit gps python lib ( The bit I really need to work )

Its also not appearing as a USB device:

lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

This is my wiring plan

1  - Power - +3.3V - 
2  - Power - +5V - Accelrometer
3  - I2C -  I2C1 SDA - Accelrometer
4  - Power - +5V - GPS
5  - I2C -  I2C1 SCL - Accelrometer
6 - Ground - Ground - GPS
7
8  - BCM 14 - TXD - GPS
9
10 - BCM 15 - RXD - GPS
11
12
13
14 - Ground - Ground - Accelrometer
15
16
17 - Power - +3.3V - Temperature Sensour
18 - BCM 24 - GPIO - Temperature Sensour
19
20 - Ground - Ground - Temperature Sensour

I am starting it up with sudo gpsd /dev/serial0 -F /var/run/gpsd.sock

This the output of sudo stty -F /dev/ttyS0 speed 9600 baud; line = 0; -brkint ixoff iutf8 echoprt

This boot config

For more options and information see

# http://rpf.io/configtxt
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
#disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
#hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
dtparam=i2c_arm=on
dtparam=i2s=on
dtparam=spi=on

# Uncomment this to enable the lirc-rpi module
#dtoverlay=lirc-rpi

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
dtparam=audio=on

#Enavle access over USB
dtoverlay=dwc2

# Enable UART
enable_uart=1


#enable 1 wire
dtoverlay=w1-gpio,gpiopin=24

This is my cmdline.txt

sudo cat  /boot/cmdline.txt
dwc_otg.lpm_enable=0 console=serial0,115200 console=tty1 root=PARTUUID=89d21086-02 
rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait modules-load=dwc2,g_ether quiet splash 
plymouth.ignore-serial-consoles bcm2708.vc_i2c_override=1

Does anyone have any ideas? Please let me know if you need anything else

  • For when someone finds this, when I fixed the networking issues I had, it somehow fixed this as well.... – Gwilym Jul 21 '17 at 12:40
  • 1
    If you've resolved your issue yourself, please write an answer with exactly what you did. Otherwise, this question is useless on the site. – stevieb Jul 21 '17 at 12:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.