0

I just got a new Raspberry Pi 3 Model B. I am trying to set it up and when I plug it in, am only getting the rainbow screen with the little square on the upper right-hand side of the screen. From other documentation I've read, it seems that this is a too-low power supply issue. I currently have my pi plugged into a wall outlet. I would believe this, however I just ran a different pi and it worked just fine.

I believe this is actually an issue with the SD card. I have used this new pi with an old SD card and it worked just fine. With this card, I also added "boot_config=1" to the config.txt file, but I still can't get anything to happen with this new SD card.

Any ideas what might be going on, or ways I could attempt to fix it?

3
  1. As you see the old square symbol, you're trying to boot an outdated Raspbian with boot code that doesn't support the 3B. Flash a recent image.

  2. Use the official 2.5A power supply for reference. As you see the top right under voltage symbol, the VideoCore GPU has successfully loaded the boot partition, may have enabled the ARM cores, and may have started them. The bolt overlay is managed by the VideoCore and triggered by under voltage. As your Pi doesn't successfully boot the kernel, there is serious undervoltage. All Pis are tested at their factories, so there is a really low chance of your Pi being bad, but a high chance that your power supplier isn't suitable.

  • Are there particular power supplies you would recommend? I've used two different ones that came with the pi and neither work. – K. Schneider Jul 21 '17 at 19:25
  • Do you use the official 2.5A ones with the official Raspberry foundation logo? Also, did you use a recent Raspbian image that supports the 3B? If yes to both, then there's something wrong with your 3B. Does the red(!) LED flicker? – TheDiveO Jul 21 '17 at 20:11
  • I am new to using Pis in general so I'm not sure what you mean by the Raspian image. The power supply is NOT an official with the logo, however came out of starter kits from Adafruit and work for different pis. Nope the red LED is not flickering, just a solid red light (no green). – K. Schneider Jul 21 '17 at 21:20
  • You can download the Raspbian OS image from raspberrypi.org/downloads/raspbian and write it on a new mSD card. Etcher.io has a really good image writer for Linux, OS X, and Windows. Try to boot this to make sure it's not an outdated image that was in the box. – TheDiveO Jul 22 '17 at 6:42
  • Glad you could finally solve it! I remembered that unfortunately a lot of people got bitten by outdated Raspbain out-of-the-box mSDs. – TheDiveO Jul 24 '17 at 18:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.