4

I have been trying to setup Windows 98 in a QEMU environment on the Raspberry Pi (I can install it fine on my Win 7 and Linux machines). But there seems to be a weird error.

I setup the vm with a qcow2 10GB HDD, setup on a 512MB Raspberry Pi running Wheezy with an 4GB ssd class 2 being used just for the boot partition and booting up into an 32GB Pendrive (For speed and size).

I have an ISO made with it (It also happens when using an external CD rom). I configure it the same way as an normal QEMU machine.

I then run in terminal:

(Sudo -i) - qemu -localtime -cdrom win98.iso -m 256 -boot d win98.img

It boots up the setup fine but it fails when it goes to partitioning.

I then found the microsoft guide on partitioning using fdisk and when creating the partition it comes up with a verification size error.

Does anyone know how to fix this? (Should I have posted the question on another Stack Exchange website?)

Thanks - Ryan

  • Did you try other hdd image formats than qcow2? Just to narrow down the possible reasons for the problem. – Krzysztof Adamski Apr 14 '13 at 16:25
6

After hours of testing different configs I found that the CPU only worked when it was set to 486.

In the end I can run it using "qemu-system-i386 -cpu 486 -m 256" ect.

-3

Try to run ExaGear Desktop virtual machine. Read the article Virtual machine for Raspberry Pi for deatails

  • 1
    In keeping with our policy regarding informationless link-only answers, if this post is not edited to contain information that can stand as an answer, however minimal, in 48 hours it will be converted to Community Wiki to simplify having it corrected by the community. – Ghanima May 22 '17 at 17:16
  • It doesn't even emulate Windows 98 though. Its more like Wine + Qemu pre done for you. – Ryan Walmsley May 25 '17 at 18:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.