0

Last month I did a clean installation of Jessie Lite after realizing NOOBS took way too much space on my 8GB card, and as of last week I've been using it primarily as a DHCP server with pi-hole until I get some more stuff on there. This has been the first time I've had it on 24/7 instead of turning it off when I'm done by the end of the day.

Problem is, twice now it has simply stopped responding after about 3 days of uptime. Specifically:

  • The green LED stays on for about 3-4 seconds, off for 1, and back on, again and again.
  • Attempts to ssh do nothing, Putty shows an error (which I think was “Software caused connection abort”) and JuiceSSH on my phone only gets so far
  • Plugging a keyboard in directly and attempting to enter commands, Ctrl+Alt+Del, etc, also does nothing.

Both times I've had to unplug power and it booted back up just fine.

Any ideas? And where should I be looking to troubleshoot this?

Edit: I couldn't find anything suspicious in /var/log, here is the last messages file and the syslog from around the time of the last crash just in case.

  • Start from checking the log files at /var/log. – hcheung Jul 27 '17 at 0:03
  • @hcheung updated post – Kimon Kar Jul 27 '17 at 10:11
  • You are running an Apache web server? is it public facing? meaning can be access from public IP? You can also check the apache access log and error log, which should be at `/var/log/apache' – hcheung Jul 27 '17 at 10:55
  • BTW, please take a look at another post where I provided some suggestions for debug, the case might not be same as yours, but worth to check. – hcheung Jul 27 '17 at 11:03
  • Ah, I should've mentioned this. Yes, I did set up Apache just the other day but not only is it not serving anything (not even the default index), the port is also confirmed inaccessible from the outside. These are the error logs from around that time. – Kimon Kar Jul 27 '17 at 11:12
0

Could be almost anything = Pi's can be very sensitive to power glitches so wotrth trying another power block .. then you can :- 1) Try going back to the previous config. 2) Try a differennt Pi

If they all have the same issue, just set up a CRON task to reboot at (say) 2am every day ... (in the early days of the Internet, lots of Routers used to do this = some still have that option, and it improves 'reliability' no end :-) )

  • The power brick is the official recommended one for the Pi3, and I've been using it without problems since February. Of course scheduling a reboot would solve it in a way, but I'm planning on running things on it that I need to be on 24/7 and would rather make sure there's not a more permanent software solution for my current setup first. – Kimon Kar Jul 27 '17 at 10:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.