1

I'm using raspberry pi b+ and audio injector codec board wm8731.

I changed in boot/config.txt file and added dtoverlay=audioinjector-wm8731-audio, but after reboot lsmod shows drivers but aplay and arecord are not working.

error like:

[    7.482939] audioinjector-audio soc:sound: ASoC: CODEC DAI wm8731-hifi not registered - will retry
[    7.482970] audioinjector-audio soc:sound: snd_soc_register_card failed (-517)
[    9.164701] systemd-journald[117]: Received request to flush runtime journal from PID 1
[   10.439748] wm8731 1-001a: Assuming static MCLK
[   10.439789] 1-001a supply AVDD not found, using dummy regulator
[   10.441207] 1-001a supply HPVDD not found, using dummy regulator
[   10.441364] 1-001a supply DCVDD not found, using dummy regulator
[   10.441478] 1-001a supply DBVDD not found, using dummy regulator
[   10.460035] audioinjector-audio soc:sound: wm8731-hifi <-> 20203000.i2s mapping ok
[   16.885190] Adding 102396k swap on /var/swap.  Priority:-1 extents:1 across:102396k SSFS
[   19.050634] smsc95xx 1-1.1:1.0 eth0: hardware isn't capable of remote wakeup
[   20.664648] smsc95xx 1-1.1:1.0 eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
[   27.732131] random: crng init done
[   31.402168] bcm2835-i2s 20203000.i2s: I2S SYNC error!
[   31.832918] bcm2835-i2s 20203000.i2s: I2S SYNC error!
[   31.973635] bcm2835-i2s 20203000.i2s: I2S SYNC error!
[   32.062855] bcm2835-i2s 20203000.i2s: I2S SYNC error!
[ 1809.728867] bcm2835-i2s 20203000.i2s: I2S SYNC error!
[ 1809.730148] bcm2835-i2s 20203000.i2s: I2S SYNC error!
[ 1811.588596] bcm2835-dma 20007000.dma: DMA transfer could not be terminated

 **aplay error:**
aplay: pcm_write:1939: write error: Input/output error

aplay hangs while playing wave file

I'm using 3.5 mm jack with earphone for listening.

Please suggest any way to use audio injector card on raspberry pi b+

2

I can see that you are using the stereo Audio Injector card and not the Octo 8 channel card. This line :

audioinjector-audio soc:sound: wm8731-hifi <-> 20203000.i2s mapping ok

shows that ALSA has set up your audio injector card correctly. The "I2S SYNC error!" lines are part of the bcm2835 i2s driver and are standard - nothing to worry about.

You should be able to see the audio injector sound card when you type aplay -l Similarly alsamixer will give you the mixer settings and allow you to change them.

If you have onging issues, the Audio Injector cards have a support site forum.audioinjector.net

  • 1
    Great..!!!!!!!!!!! i got it working bu changing few parameters using alsamixer – Shrikant Lahase Aug 4 '17 at 6:01
  • I had the same problem with an AudioInjector card, and I needed to enable (unmute) the "Output Mixer HiFi" toggle. Thanks! – elmicha Nov 1 '17 at 13:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.