1

I have an RPi 3b running Arch Linux.

I'm attempting to run Redshift:

redshift -O 3300

The output is:

Gamma ramp size too small: 0
Failed to start adjustment method randr.
Trying next method...
Using method 'vidmode'.

Nothing happens! The Arch Arm Wiki says:

The X.org driver for Raspberry Pi can be installed with the xf86-video-fbdev or xf86-video-fbturbo-git package.

Both are installed, I've alternated removing and reinstall them. No luck. Any advice? Redshift has become essential these days. :D

1

You'll need to get the experimental OpenGL driver to run Redshift. First, upgrade to latest kernel/firmware:

rpi-update
apt-get update
apt-get upgrade
apt-get dist-upgrade

Then, run raspi-config, go to Advanced Settings and enable the experimental OpenGL driver. Reboot and try running Redshift again.

Edit: sorry, I completely overlooked the Arch Linux. Hopefully, you still have rpi-update and raspi-config on it.

  • I do not! There appears to be some forks for arch, but they look pretty suspect. Any recommended ways of enabling the driver or rasp-config within Arch? It did work within Raspbian using the method you described. – Goodroot Aug 2 '17 at 18:10
  • @Goodroot Sorry, I have no experience with Arch. AFAIK Raspbian is the only officially supported OS on RPi, everything else is "community effort". The moment you ditch Raspbian, you lose that support, at which point you may as well ditch the RPi and go for a cheaper and more powerful board. – Dmitry Grigoryev Aug 2 '17 at 19:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.