1

I recently bought a 7-inch touchscreen, from Adafruit, for my RPi3. I downloaded the latest disk image for Raspbian, did all the updates per the startup instructions:

sudo apt-get update  
sudo apt-get upgrade
sudo apt-get install --reinstall libraspberrypi0 (etc...)

I double-checked all the connections... The display ribbon cable (both sides), the power to the display, the large ribbon cable on the display as well as the tiny ribbon cable to the display.

I still get nothing. The screen is still pitch black, regardless of what I try.

My first question is, when power is supplied to the touchscreen display is it supposed to turn colors or something? My other monitors (non touchscreen) will turn blue or white when the power is on, even if the RPi3 is not powered on. This touchscreen stays completely pitch black giving no indication that it is even powered. Is this behavior normal for this product?

Secondly, what are my next steps? I've ensured my Pi has the latest Raspbian with all the updates. I've checked all the wiring. I'm still stuck with a completely dark screen. At this point do I conclude the monitor is a dud?

  • 1
    My next step would be to post pictures and your question on the Adafruit forums they would be the only people who could RMA it, so asking here may result in you having to do the same thing all over again. – Steve Robillard Aug 3 '17 at 19:54
  • To bring some closure to this. I returned the touchscreen to Amazon. I reluctantly bought a new one (exact same). It immediately turned on. The first one had something wrong with it. – twegner Aug 9 '17 at 3:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.