1

I'm having trouble installing any package on my Raspberry Pi v1 B. Whenever I run apt-get install [any package here], it always failed with E: [package name] has no installation candidate. I don't understand why this is so, as it was working some time ago.

My APT sources.list

deb http://repozytorium.mati75.eu/raspbian jessie-backports main contrib non-free

My APT sources.list.d:

raspi.list:

deb http://archive.raspberrypi.org/debian/ jessie main ui
# Uncomment line below then 'apt-get update' to enable 'apt-get source'
deb-src http://archive.raspberrypi.org/debian/ jessie main ui
deb http://mirrordirector.raspbian.org/raspbian jessie non-free contrib rpi

jenkins.list:

deb http://pkg.jenkins-ci.org/debian binary/

apt-get update output:

Get:1 http://repozytorium.mati75.eu jessie-backports InRelease [6,842 B]
Hit http://archive.raspberrypi.org jessie InRelease
Hit http://mirrordirector.raspbian.org jessie InRelease
Get:2 http://repozytorium.mati75.eu jessie-backports/main armhf Packages [111 kB]
Hit http://mirrordirector.raspbian.org jessie/non-free armhf Packages
Hit http://archive.raspberrypi.org jessie/main Sources
Hit http://mirrordirector.raspbian.org jessie/contrib armhf Packages
Hit http://mirrordirector.raspbian.org jessie/rpi armhf Packages
Hit http://archive.raspberrypi.org jessie/ui Sources
Get:3 http://repozytorium.mati75.eu jessie-backports/contrib armhf Packages [20 B]
Get:4 http://repozytorium.mati75.eu jessie-backports/non-free armhf Packages [14.1 kB]
Hit http://archive.raspberrypi.org jessie/main armhf Packages
Hit http://archive.raspberrypi.org jessie/ui armhf Packages
Ign http://pkg.jenkins-ci.org binary/ InRelease
Hit http://pkg.jenkins-ci.org binary/ Release.gpg
Hit http://pkg.jenkins-ci.org binary/ Release
Hit http://pkg.jenkins-ci.org binary/ Packages
Ign http://pkg.jenkins-ci.org binary/ Translation-en_GB
Ign http://pkg.jenkins-ci.org binary/ Translation-en
Ign http://repozytorium.mati75.eu jessie-backports/contrib Translation-en_GB
Ign http://repozytorium.mati75.eu jessie-backports/contrib Translation-en
Ign http://repozytorium.mati75.eu jessie-backports/main Translation-en_GB
Ign http://repozytorium.mati75.eu jessie-backports/main Translation-en
Ign http://repozytorium.mati75.eu jessie-backports/non-free Translation-en_GB
Ign http://mirrordirector.raspbian.org jessie/contrib Translation-en_GB
Ign http://repozytorium.mati75.eu jessie-backports/non-free Translation-en
Ign http://mirrordirector.raspbian.org jessie/contrib Translation-en
Ign http://mirrordirector.raspbian.org jessie/non-free Translation-en_GB
Ign http://mirrordirector.raspbian.org jessie/non-free Translation-en
Ign http://mirrordirector.raspbian.org jessie/rpi Translation-en_GB
Ign http://mirrordirector.raspbian.org jessie/rpi Translation-en
Ign http://archive.raspberrypi.org jessie/main Translation-en_GB
Ign http://archive.raspberrypi.org jessie/main Translation-en
Ign http://archive.raspberrypi.org jessie/ui Translation-en_GB
Ign http://archive.raspberrypi.org jessie/ui Translation-en
Fetched 132 kB in 17s (7,731 B/s)
Reading package lists... Done
  • 1
    I have taken care of the hxxp problem. – Gene Dela Rosa Aug 4 '17 at 13:29
2

Fixed it by editing the deb http://mirrordirector.raspbian.org/raspbian jessie non-free contrib rpi to deb http://mirrordirector.raspbian.org/raspbian jessie main non-free contrib rpi

-1

try running "sudo apt-get update" and "sudo apt-get upgrade"

This may solve your problem.

  • Ran it already, did not work. – xiurobert Aug 5 '17 at 0:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.