0

I have a 512MB rev B Pi that seems to be working just as it should. But my TP-link WN725N v2 just doesn't seem to work with it. I run the latest version of Raspbian Wheezy and according to several posts on the internet, including here, http://www.raspberrypi.org/phpBB3/viewtopic.php?t=25875 this version of the OS and this device should work "out of the box", without any external power supply. But mine doesn't.

I've tried both while running HDMI and a keyboard, as well as only running ethernet and going through ssh. I've also tried two different power supplies. A Galaxy S 2 5V 1A-adapter and another, more powerful one. Both work fine along with this other dongle, a TP-link too, I think the model name is 723N.

But I get nothing while trying mine. The OS recognizes a USB device is connected, but does not recognize it as a wifi0.

Oh, and I did confirm on my desktop PC that the dongle indeed does work.

What do I do next?

2

I had some sort of same problem here:

Raspberry Pi wifi wlan0

I got the answer from the raspberry pi official forum.

There are two versions of this wifi adaptor. V1 has the driver included in most images, V2 requires you to download and install a driver as it is not included in the Linux images.

It appears you probably have V2 and need to download and install the driver. You can determine the wifi version you have if you use command lsusb. This will list the WN725N V2 as

Bus 001 Device 004: ID 0bda:8179 Realtek Semiconductor Corp.

The important info is the ID 0bda:8179.

If it shows this you need to download the driver. If you use a recent version of Raspbian there are precompiled versions available.

Precompiled versions of the driver are available for Raspbian as follows

for 3.6.11+ #538, #541, #545, #551 and #557 use 8188eu-20130830.tar.gz

for 3.6.11+ #524, #528 or #532 use 8188eu-20130815.tar.gz

for 3.6.11+ #371 up to #520 use 8188eu-20130209.tar.gz

Use command uname -a to determine the version you have e.g.

pi@raspberrypi ~ $ uname -a
Linux raspberrypi 3.6.11+ #551 PREEMPT Mon Sep 30 14:42:10 BST 2013 armv6l GNU/Linux
pi@raspberrypi ~ $

Download and install the driver using the commands

wget https://dl.dropboxusercontent.com/u/80256631/8188eu-2013xxyy.tar.gz <--set data code for driver version above
tar -zxvf 8188eu-2013xxyy.tar.gz                                         <--set data code for driver version above
sudo install -p -m 644 8188eu.ko /lib/modules/3.6.11+/kernel/drivers/net/wireless
sudo insmod /lib/modules/3.6.11+/kernel/drivers/net/wireless/8188eu.ko
sudo depmod -a

You can check if the driver is loaded OK with command ifconfig It should show wlan0 something like

wlan0     Link encap:Ethernet  HWaddr a0:f3:c1:25:7d:28
          inet addr:192.168.16.15  Bcast:192.168.16.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:125431 errors:0 dropped:305 overruns:0 frame:0
          TX packets:5821 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:21001551 (20.0 MiB)  TX bytes:762826 (744.9 KiB)

Also I had the #474 which needs: 8188eu-20130209.tar.gz

1

This might benefit users like me who did not understand why the wn725n rev 2 (ID 0bda:8179) did not work on the latest Openelec distro (as of december 2015, this should have worked "out of the box").

It was the wi-fi password. No need to install drivers or configuring anything: it did not connect to my router when I had a looooong (32+ chars) password, but as soon as I changed the password to a shorter one (less than 12 chars) it started working "out of the box".

I tried it because it so happen to be the case with my new HP laser printer. Loooong passwords are a problem for certain devices.

0
1. uname -r //gives ur rp version number 
2. Based on the rp version number choose ur 8188eu tar file from http://www.raspberrypi.org/forums/viewtopic.php?p=462982#p462982
3. wget https://dl.dropboxusercontent.com/u/80256631/8188eu-201xyyzz.tar.gz
4. tar -zxvf 8188eu-201*.tar.gz
5. sudo cp rtl8188eufw.bin /lib/firmware/rtlwifi //not needed anymore if your operating system is above 3.10.33+
6. sudo install -p -m 644 8188eu.ko /lib/modules/`uname -r`/kernel/drivers/net/wireless
7. sudo insmod /lib/modules/3.10.33+/kernel/drivers/net/wireless/8188eu.ko
8. sudo depmod -a
9. sudo reboot
0

You could try the following commands. I have tested it on Raspbian and Arch Linux.

sudo wget https://github.com/lwfinger/rtl8188eu/raw/master/rtl8188eufw.bin -O /lib/firmware/rtlwifi/rtl8188eufw.bin
sudo reboot
0

Today I successfully installed my TP-Link WN725N USB WiFi dongle.

Warning: If the system is updated, the driver must be re-installed for the WIFI Dongle to work

Installing the Driver as a binary

Update the system with rpi-update first, so when I then run uname -r Something like this is displayed.

Linux hostname .... 4.1.6-v7+ ... PREEMPT Debian ...

Search for 4.1.6-v7+ on https://www.raspberrypi.org/forums/viewtopic.php?p=462982 so the following binary should be used:

8188eu-v7-20150818.tar.gz

Adjust the script like so:

export VERSION=$(uname -r)    
export FILE=8188eu-v7-20150818.tar.gz

wget https://dl.dropboxusercontent.com/u/80256631/$FILE
tar -zxvf $FILE
install -p -m 644 8188eu.ko /lib/modules/$VERSION/kernel/drivers/net/wireless
insmod /lib/modules/$VERSION/kernel/drivers/net/wireless/8188eu.ko
depmod -a

Alternatively building the driver from source

I tried to download and install the driver, but this failed for some reasons I don't know. So I built it from source using this tutorial:

apt-get update
apt-get install linux-headers-$(uname -r)
apt-get update
apt-get install build-essential
apt-get install git
git clone https://github.com/lwfinger/rtl8188eu
cd rtl8188eu
make all
make install
insmod 8188eu.ko

Now the device shows up when I execute lsusb:

lsusb -t

/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=dwc_otg/1p, 480M
    |__ Port 1: Dev 2, If 0, Class=hub, Driver=hub/5p, 480M
        |__ Port 1: Dev 3, If 0, Class=vend., Driver=smsc95xx, 480M
        |__ Port 2: Dev 4, If 0, Class=vend., Driver=r8188eu, 480M
        |__ Port 4: Dev 5, If 0, Class='bInterfaceClass 0xe0 not yet handled', Driver=btusb, 12M
        |__ Port 4: Dev 5, If 1, Class='bInterfaceClass 0xe0 not yet handled', Driver=btusb, 12M

Configuring the Interface

Setup

apt-get install wpasupplicant

Setup /etc/network/interfaces

# ...
auto wlan0
allow-hotplug wlan0
iface wlan0 inet dhcp
wpa-conf /etc/wpa_supplicant.conf

Setup /etc/wpa_supplicant.conf

network={
    ssid="MySSID"
    scan_ssid=0
    proto=WPA
    key_mgmt=WPA-PSK
    psk="MyPassword"
    pairwise=TKIP
    group=TKIP
}

Now I can fire up the interface like so:

ifdown wlan0
ifup wlan0

Update:

I added auto and allow-hotplug settings in the interface configuration, so that the device would connect to the Wifi automatically.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.