0

Brand new RPi 3B built with NOOBS Raspbian.

Like the title says, I can ping www.google.com just fine, but chromium won't load it, or any other site.

$ netstat -rn
Destination  Gateway     Genmask       Flags MSS  Window irtt Iface
0.0.0.0      10.0.0.1    0.0.0.0       UG    0    0      0    wlan0
10.0.0.0     0.0.0.0     255.255.255.0 U     0    0      0    wlan0

$ ip addr

wlan0 inet 10.0.0.34/24

no proxy, no firewall, sitting behind a comcast modem/router

  • The only thing I can think of is a firewall blocking www traffic, but accepting ICMP (Ping) traffic or do you connect to a public WiFi that needs accepting the WiFi policy? – MatsK Aug 8 '17 at 6:52
  • Do you have a proxy you need to configure? – stevieb Aug 8 '17 at 12:30
  • From a terminal, can you try typing: curl -S google.com and post the result. – MatsK Aug 9 '17 at 10:05
  • If you haven't curl install, install it with "sudo apt install curl" – MatsK Aug 9 '17 at 10:14
0

I had the same issue on my Orange Pi Win Plus running Raspbian Jessie.

Have you tried to access the Chromium settings? In my case none of the pages (nor online nor settings which should be accessed offline won't load).

Instead i installed Iceweasel (Firefox):

sudo apt install iceweasel

Chromium won't work but at least I can surf the web.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.