0

I have a problem with my LCD Touchscreen.

I'm using a 3.5inch Waveshare LCD and Raspberry Pi 3 with Raspbian OS. The LCD usually worked and could display the desktop. But then suddenly it was unable to display the desktop. The screen showed just a black screen with a pointer, but the pointer won't move even though I'm using wireless mouse.

I can log in via SSH using PuTTY and can see the desktop on my laptop using VNC.

At first, the LCD displayed the boot command line, but then it freezes when trying to display the desktop. Its touch screen function also does not work.

I also got the error message rc.local compatibility failed when booting the Pi.

So, why can't my LCD display the desktop? I didn't make any changes to the configuration.

  • "I didn't make any changes in my configuration" - well, you obviously did something. – Dmitry Grigoryev Aug 8 '17 at 15:36
  • i mean yesterday it can show the desktop then i turned it off until today i turned it on, the lcd didn't show anything except command line while booting. @DmitryGrigoryev – rafifadl Aug 8 '17 at 17:02
  • Assuming the last time you successfully started into desktop was yesterday, did you do any updates, install or software since that moment? Did you shut down gracefully yesterday? – Dmitry Grigoryev Aug 8 '17 at 17:09
  • no, i didn't update or install any software. now I try to open the desktop with VNC. my LCD still freeze but my touch screen worked. I saw the pointer move on VNC everytime i'm using my touch screen. @DmitryGrigoryev – rafifadl Aug 8 '17 at 19:47
  • edited the post, adding an error message when booting. – rafifadl Aug 8 '17 at 19:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.