I'm working with a pi 3, I use Jessica img and waveshare driver :


I followed the instructions and the touchscreen 3.5" is working except for touch feature. I tried with other driver like adafruit https://cdn-learn.adafruit.com/downloads/pdf/adafruit-pitft-3-dot-5-touch-screen-for-raspberry-pi.pdf or https://www.elecrow.com/35-inch-480x320-tft-display-with-touch-screen-for-raspberry-pi-p-1385.html but none of them allow the touch feature to be enable.

I was wondering if it was the pi which had a hardware problem since the touch screen was doing perfectely with a pi 2 : display GUI and touch responsive.

In my last attempt I connect the pi with an 7" offical touchscreen https://www.kubii.fr/ecrans-pitft-raspberry-pi/1131-ecran-tactile-officiel-7-800x480-640522710829.html and it was good.

So now I'm left stupefy and I hav no idea why it's working and not with 3.5 screen. I woul like to heard your thought on my problems thanks.

Hope we can find the reason :)

ps: I have not enought point to put more than 2 link... (T_T)

  • Hie, I'm not sure if there is an official display in 3.5" format but I saw many touchscreen 3.5" in the market.
    – T.Dunglas
    Aug 23, 2017 at 12:37

1 Answer 1


i cannot say if is generic or not that screen, but usually, you have to change the driver, mabe u PI3 has the driver for 7" enabled and not for 3.5" screen, I have several generic screens, so when I want to use 7" screen I put the command ./LCD-7... and I have to change the screen, but if I want to use 3.5" screen I have to put ./LCD-35..., also if you want to use some screen but u have HDMI connected it will take HDMI screen by default, u have to change that in config file

  • Thanks you for your response, I already tried the driver using ./LCD35-show, it allow to display the GUI on the touchscreen but it won't respond to any touch event with my finger/pen/object.
    – T.Dunglas
    Aug 23, 2017 at 12:40
  • it depends on screen model but , if is connecteb via pins, some pins of that handle touch interaction, be sure they are well connected Aug 24, 2017 at 17:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.