1

I have an RPI2 what I want to use as a "developer platform" with git and mysql server. I using dyndns for remote access, but! when I home I can access it from 192.168.1.125 and when I'm remote I can from "myrpi.dynalias.net". How to access Rpi from home with this address, too?

  • Have you done a port forwarding in your firewall to get "myrpi.dynalias.net" to work? – MatsK Aug 10 '17 at 21:26
  • Yes, the "myrpi..." working from ouside of thr the network, but insode it not – Feralheart Aug 10 '17 at 21:28
3

Add 192.168.1.125 myrpi.dynalias.net to your hostfile.

In windows it is normaly located at:

c:\Windows\System32\Drivers\etc\hosts

Linux:

/etc/hosts
1

Your router/firewall probably is probably blocking the NAT loopback, some firewalls block it by default as security measure and you must manually create a rule to allow it. How to enable NAT loopback depends on the make and model of your firewall, you can probably, searching for "[router/firewall model] nat loopback" would be the place to start.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.