1

The problem is that I can't get it to work while using linux, I can SSH just fine into it on my Windows machine but on my laptop running arch, it doesn't seem to be able.

I've followed the steps I found online, adding dtoverlay=dwc2 to your config.txt, adding modules-load=dwc2,g_ether to your cmdline.txt and then creating a blank file called ssh, and giving that it already working on a Windows system, it's clearly not the problem.

On my linux machine, I have the avahi-daemon running and if I issue an avahi-browse -all I see

enp0s20u3 IPv6 raspberrypi                 Workstation       local

If I check my networkmanager, it shows up as an ethernet device. If I check ifconfig, it also shows up with its own interface.

Does anyone have any clue as to why it isn't working?

*Edit: The only way I've figured out how to SSH into it is by using avahi-browse -art and marking down its address and interface, then

ssh pi@(address)%(interface)
2
  • You could put your edit as an answer, that would make it clear your problem is solved. Aug 11 '17 at 10:26
  • 1
    @dmitry it's more of a compromise, I haven't figured out how to enter pi@raspberrpi.local instead of having to enter output I get from avahi. Aug 11 '17 at 17:26
0

In Linux Mint 18.3, I have to go into Network Connections and edit the entry that shows up when the Zero W is plugged in. Go to the IPv4 Settings tab, and change Link-Local Only. After I do this, and wait about 15 seconds or so, I get a notifcation that Wired Connectiong #2 was made. Wired Connection #1 is my connection to my router; I am not on wifi. Then I can SSH in or just ping the Zero W.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.