I wonder if anyone can help, I'm a total beginner.

I have a Pi running Raspbian Wheezy and I'm trying to connect using Real VNC. I've spent hours trying to get VNC Connect to run on my Pi but so far no joy.

I have tried downloading the file from the website but I guess I need to unpack it? I have no idea how to do this... I need some really really basic instructions on how I can get this to work. I've tried clicking on things and running various commands in the Terminal but I always get replies like unable to locate package.

2 Answers 2


I'm a beginner like you but I think I can help you.

You should be using Raspbian Jessie. Wheezey is obsolete.

You can download Raspbian Jessie from here. Choose RASPBIAN JESSIE WITH DESKTOP. It has RealVNC Server pre-installed.

(maybe you could also use sudo apt-get update then sudo apt-get upgrade then sudo apt-get dist-upgrade commands to get Raspbian Jessie, but I'm not sure, it may not be enough).

Make sure you have VNC Server enabled by running:

sudo raspi-config go to Interfacing Options > VNC > Choose Yes

Now you should be able to connect to your Pi via RealVNC Viewer or a similar program on your PC.


The Unable to locate package error is most likely caused by either not having updated the packages or not having the correct OS.

Like @Rururusiu said, you should probably try sudo apt-get update, which will update all the available packages, and then try and install it. If that does not work, you will most likely have to update to Raspbian Jessie.

I have a different VNC client installed and I followed this tutorial:


Obviously, this is to install NodeJS on it, but if you follow from the "Apply Raspbian updates" section to the "Prepare remote desktop" section, this will help you. Another nice addition if you don't want to have to VNC to get files on and off the Raspberry Pi is also creating a SAMBA server on it (as shown in the next step).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.