0

TL;DR version:

I have recently installed Openelec 8 on a RPI2 and I didn't like the new interface so I downloaded Confluence. Almost each time it booted (except after reboot) the interface, regional settings etc was set to default. After week it only boots but add-ons and add-ons main menu item disappeared and I can't access most of settings because when I try to nothing happens.

The question is: Is it caused because of Openelec bugs or is this behavior caused by bad SD card?

Long version:

It's a long time I'm using Openelec. I started using it with version 6 and this was installed to the same SD card as the new problematic installation of Openelec 8. That version had similar problem, it couldn't remember the regional settings else it worked fine. Maybe once it forgot TV channels but that's not that important because few days after the TV card was burnt during storm. I forgot to mention that I bought the two available HW codec for RPI2 and enabled it. When we got used to English enviroment (that wasn't problem for me) and that the weather add-on won't be used then it worked fine.

Then Openelec 7 was released, so I took a new SD card and left the old one as backup. I made fresh installation of it and it worked. I just forgot to insert keys for HW codecs acceleration but it was not necessary, no lags appeared.

Few weeks ago one add-on worked half way. It was add-on of regional TV. Some movies/tv shows were working but unfortunately not the one I required. The problem was that it stopped working even for the episodes I already saw so I decided to make new installation of new version of OE. So I made fresh installation of OE 8.0.4 to SD card which was with OE6. I installed everything as before and it worked fine so I used the SD with OE7 for other purpose.

Changes in OE8: I didn't like the new grafical interface because some information wasn't visible like in Confluence. So I added SuperRepo and installed the Confluence appearance. I also set language, keyboard layout and on screen keyboard layout. Then I customized weather and so on. It worked fine for four days then I remembered that I wanted to enable the HW codecs. Since that time I enabled it, the settings of Kodi is always set to default after boot. I tried fresh install without HW codecs but nothing helped and week after the installation it at first forgot half of add-ons and from the other was working just two. On the second try it forgot every add-ons and half three quarters of settings are inaccessible.

Used HW: RPi: Raspberry Pi 2 SD for OE6 and OE8: 16GB Kingston Class 10 SD for OE7: 8GB A-Data Class 10

Weird is that only Kodi settings was alwas forgotten, but settings of keyboard layout and enabled ssh remained. After longer time it forgets also Kodi add-ons.

I would like to know if I should get rid of untrustwothy Kingston SD or that the problem is in Openelec for RPi.

  • 2
    If there was an issue with the SD card you would be facing much more serious issues like the OS failing to boot, e.t.c. I think you are experiencing some kind of bug. I suggest a clean install and see if the problem persists. If it does try a different SD card, but I don't think that is the issue. – Darth Vader Aug 13 '17 at 12:59
  • The problem persists even with new installation, I'll try different SD card. – Jirka Picek Aug 14 '17 at 10:31
  • I'm surprised a new installation on the same SD card is problematic. Could you detail how you are installing OpenELEC? – Darth Vader Aug 14 '17 at 12:43
  • I downloaded image, then I copied it in linux with dd command. The whole command was like dd -if oe.img -of /dev/smblk0 -bs 64K. Then in RPi I installed SuperRepo from srp.nu to get Confluence because I couldn't find it in base repositories. Just fun fact: both mentioned card in question was bought with micro SD to SD adapter and when I used adapter made by Kingston the SD card showed in /dev folder but I couldn't mount it, but with the other adapter it worked. – Jirka Picek Aug 14 '17 at 13:06
  • On new SD card it seems fine, but I just powered it off and then again on only once, so it's not tested enough. – Jirka Picek Aug 16 '17 at 2:48
0

I bought new SD card and it's working fine now. The first time I tried it with new SD card there was an error because it hanged on rainbow screen, but the second time it's working for three weeks without bug now and I hope it will work happily ever after.

Explanation could be in linux. It can handle some errors. Once my friend had a PC with hard drive which got Alzheimer's disease (it couldn't keep information). I tried to install Win7 on it several times but it couldn't run the second part of installation process after first reboot. After BOIS screen an error appeared. Then I tried to install linux (with GUI) and it was working fine for two weeks and then the disk went to silicon heaven. From this experience I think that the linux has good ability to self heal.

OpenElec is based on linux kernel so I guess that the SD card has similar problem to hard drive I mentioned in previous paragraph. Linux repaired self and all programs including Kodi as long as he could. The repair of settings could be just reverse to the older one and after while when there was bigger amnesia it couldn't restore all the memory.

That's my point of view. If you have anything to prove or disprove I'd be glad to hear another opinions or facts.

PS: I'm sorry for my English, it's not my native language.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.