I'm not sure why this happens. The Bluetooth mouse works fine until I turn on the wi-fi, and then it almost immediately stops responding. I can still use a wired mouse though, and if I turn wifi off I can reconnect the Bluetooth one. Is there a way I can get both things to work at the same time?

I have a Raspberry Pi 3. I don't have a wi-fi or Bluetooth thing plugged into it (unless the tv I am using as a monitor somehow does this), so I assume these are built-in functions to the Pi.

The Bluetooth keyboard that I have connected still works when wifi is on.

  • As yuppie BT keyboard all works correctly after switching on WLAN, I would suspect an inferior mouse design that doesn't have any proper shielding. Can you try with a different BT mouse from a renown manufacturer (not a fake one sold under the brand for a few dimes)?
    – TheDiveO
    Commented Aug 14, 2017 at 16:19
  • @TheDiveO I'm using a Mac Bluetooth mouse. Although it is a bit old, it works fine with wifi on my regular computer. Unfortunately, I don't have another BT mouse I can use. Commented Aug 15, 2017 at 18:12

2 Answers 2


It's been observed and verified for quite some time now that the RPi3 built in Bluetooth and Wifi don't play nice together. Your best bet would be to replace one or the other service with a dongle, and disable its onboard counterpart.

  • Have they fixed this yet, or is this still the case? Commented Jan 27, 2019 at 4:06

This usually happens on cheap WIFI/BT adapters which use the same antenna for both functions. Some devices can play nice and share the common antenna, others don't.

The simplest solution would be to buy a separate USB WIFI dongle and use it instead of the built-in WIFI. Another option is to buy a different BT mouse which is known to work with the RPi. Several examples of such devices can be found here.

  • OP said explicitly that s/he doesn't use an USB Wlan/BT dongle, but uses the builtin WLAN and BT of Pi 3B.
    – TheDiveO
    Commented Aug 14, 2017 at 16:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.