0

I'm trying to install Postgis 2.3 on Pi running Jessie. I have tried using apt-get but this installs the Postgis for Postgres 9.4. And hence I cannot use it on the 9.6.

So I've tried to compile from code using this source. But I end up with

> checking for pg_config... /usr/bin/pg_config You need to install
> postgresql-server-dev-X.Y for building a server-side extension or
> libpq-dev for building a client-side application. configure: error:
> the PGXS Makefile  cannot be found. Please install the PostgreSQL
> server development packages and re-run configure.

after I run ./configure

Has anyone tried to find out how one can go on achieving this. I've also tried with a different .config file but it doesn't seem to help.

  • Have you tried to install the missing libs the script is complaining about? – Dmitry Grigoryev Aug 14 '17 at 9:43
  • Yes I have. But when I try installing the libs it says I have to remove some existing libs. And when I did that and installed this one my psql stops working since it was using the previous libs. – AbsoluteSith Aug 14 '17 at 14:17
0

Use these following commands, this will solve the error:

sudo apt-get install postgresql postgis

and last:

sudo apt-get install libpq-dev

Referring

  • The problem with this type of installation is it will target x64 type of architecture which would not work on a pi. – AbsoluteSith Aug 14 '17 at 14:16
  • 1
    Please visit this link – Hamed Aug 15 '17 at 4:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.