2

When I run raspistill -o cam.jpg I get

mmal: mmal_vc_component_enable: failed to enable component: ENOSPC
mmal: camera component couldn't be enabled
mmal: main: Failed to create camera component
mmal: Failed to run camera app. Please check for firmware updates

I've tried to update the raspi, disable and enable the camera and reboot. The camera work perfectly fine yesterday.

  • 1
    Have you checked the sudo raspi-config and sudo rpi-update ? – kuzeyron Aug 15 '17 at 11:19
1

try running: vcgencmd get_camera

it should output something like:

supported=1 detected=0

I recently started messing around with a camera on my pi and I found the connectors to be really fussy and hard to securely seat on the board. If it says detected=0 then you probably just need to push the ribbon in on the board or the camera.

0

I get this error every so often. Try turning it off and reseating the ribbon, I usually do both ends to save time. I don't know what causes it as mine are all fixed in place and not much nudges the ribbon? Craig

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.