0

I am using a proper voltage and amperage power supply as well. 5V 3A (it is a long cable so needed more amps). Anything less than 3A does not even turn the pi on at all. Please Help!

I currently have a few Raspberry Pi 3's. What is odd is they ONLY power on if the power cord is plugged in to the wall first THEN the pi. If I unplug from the wall and plug it back in, it won't boot up. Thoughts?

  • 2
    "They", are you powering multiple devices? What power supply, exactly, are you using? Is there anything plugged into RPI? For reference I have no trouble powering a headless device with no USB attachments off 500mA, although it does throw warnings during heavy computes. The official 2A supply is enough to run it with a touch screen display. The voltage drop in a USB cable shouldn't be significant enough to affect power, BUT it may affect the power mode detect if you violate USB spec with a >5m cable. If you ARE using custom cables, you should use a scope to see the power on voltage droop. – crasic Aug 15 '17 at 22:20
  • The symptoms you are experiencing are typical of a inrush limited supply. There is inrush current due to the supply starting up, and an inrush current due to RPI booting up. If the RPI current draw is high this may trigger the inrush limiter and not allow the supply to start. By plugging the wall supply first you overcome the supply inrush and leave more "room" for the raspberry pi inrush. – crasic Aug 15 '17 at 22:23
  • Sorry to clarify THEY means each one that I have tried. There is only 1 pi at a time – Fyb3roptik Aug 15 '17 at 22:31
  • The setup is a self built arcade that is about 10 ft long and the power is separated between the cabinets (the cabinet is 3 segments). The pi is in the front and the power in the back. I am running 18awg wiring through most of it and cat 6 on either end. I tried a 3A power supply and it wasn't enough. I have a 4A one but I get the lightning bolt and have ordered a 5A one to try that one. 5V is getting through just fine, just seems to be a current issue – Fyb3roptik Aug 15 '17 at 22:34
  • There is no way a functional, not-burning-and-on-fire raspberry pi is drawing anywhere near 3A. There is something else going on.The lightning bolt is determined by the 3.3V Supply and can show if an on-board device or GPIO is drawing too much power. 3.3V devices use the onboard regulator and limited to a few hundred mA. The 3.3V regulator will work down to 4V or lower. Remember GPIO starts in PULLUP HIGH and anything connected to it like an LED will immediately draw current on power on – crasic Aug 15 '17 at 22:44
1

I am afraid that "more amps" is meaningless. The Pi will only draw as much current as it needs, and will have problems if the VOLTAGE is too low. See Raspberry Pi Power Limitations for a more detailed discussion.

It is impractical to power the Pi (or any other low voltage device) with such a long lead. There are established electrical engineering techniques to power over extended distances, but ALL involve moving the 5V regulation closer to the load.

If you MUST supply remote power I would suggest a different solution. Use a 5V switch mode regulator e.g. a UBEC to run each Pi, and a 12V (or higher) feed (and don't even think of using CAT5 or 18AWG, even at 12V). The cost of 5V switch mode units, which are readily available, would actually be less than the cost of a suitable cable.

If I was trying to do something similar I would NOT use the µUSB connector, but feed power via the expansion header. This is discussed in the link above.

If you want other options you might consider the EE site. This is really an EE question, which only peripherally involves the Pi.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.