0

This SD card has Kali loaded for Raspberry pi 3.

Some how I corrupted sd card by editing config.txt file in windows 10 machine, after then sd card was unrecognizable by neither machines windows or the raspberry pi with Debian, but if I put this sd card in raspi it will boot to the kali desktop.

Corruption I had in this sd card causing somethings don’t work in desktop like, wifi connection, it said it’s connected, but if ping any where it comes back with unreachable site, if I ran ifconfig there are ip, mask, and gateway all there, but when I try ifdown or ifup it comes with unknown interface wlan0.

So clearly something still corrupted I want to reflash sd card, but other machines don’t recognizing this sd card.

I tried fsck to itself but it said drive is mounted so can’t do anything.

  • 2
    Can you not reformat the SD card? Can the other computers even recognise that the SD card is plugged in? – Quintin Balsdon Aug 17 '17 at 8:50
  • Windows machine doesn't even know it plugged in. Raspi doesn't know either so I thought it was goner but when plug in to boot raspi it will boot to X windows so it's still live. I couldn't format nor reflash to reset OS. No machines recognize to format the SD card. – Lao Aug 18 '17 at 18:08
  • I got it fixed some how, this is weird problem. I download SD card Formatter, plugged in SD card to USB SD card reader to gain a drive letter so I can tried to format SD card, first time it tried to format with out error showing busy for 10 minutes so I stop it and tried it for second times it worked, then I was able to reflash Kali again and it seems work better than before, I was able to edit config.txt got right resolution on display had no problem with SD card any more. – Lao Aug 20 '17 at 4:13
0

I had the same problem. I ended up inserting the cards into a digital camera, formatting them and plugging the camera into a computer. I left the card in the camera, ran DiskUtility (OSX - what ever OS your using use the default formatting tool)

Then I ran the SD formatter tool, followed by Etcher.

It might be over kill, you can probably skip reformatting with the OS tool

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.