0

I have a Raspberry PI 3 (B). I'm accessing it remotely via wlan0 - built in WiFi chip.

Now, for sake of pen testing i got myself a separate USB WiFi card. The problem is that, after i finish experimenting with wlan1, my PI disables both wlan0 and wlan1 so i can't access my PI anymore unless i connect it to a monitor and fix things while directly connected.

How to disable turning off certain device like wlan0?

0

wlan0 might go into Sleep Mode, because it hadn't been used. Check this with iw wlan0 get power_save

If the result is Power save: on, you can disable it with iw wlan0 set power_save off.

More information about iw can be found in the man page.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.