1

I'm trying to install Jasper with this guide.

Now i'm hanging with the following problem: i try to use the command sudo apt-get -t experimental install phonetisaurus m2m-aligner mitlm libfst-tools, but it runs on this error(s):

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
m2m-aligner : Depends: libstdc++6 (>= 5.2) but 4.9.2-10 is to be installed
mitlm : Depends: libmitlm0 (= 0.4.1-2) but it is not going to be installed
        Depends: libstdc++6 (>= 5.2) but 4.9.2-10 is to be installed
phonetisaurus : Depends: libfst4 (>= 1.5.3+r3) but it is not installable
                Depends: libstdc++6 (>= 5.2) but 4.9.2-10 is to be installed
E: Unable to correct problems, you have held broken packages.

I tried to install them manually - without success.

Once i use the command /home/pi/jasper/jasper.py the output says this:

OSError: Can't find command 'phonetisaurus-g2p'! Please check if Phonetisaurus is installed and in your $PATH.

Does anyone know what that means? Of course i checked the command phonetisaurus-g2p and can confirm that this is not working.

Any help is appreciated.

0

Not sure if this is going to help you at this moment, but anyway. I ran into this problem as well , what fixed it was:

sudo apt-get clean 
sudo apt-get update
sudo apt-get search $package #ex:libfst-tools
sudo apt-get install $package

After you have installed all the dependencies and have proceeded with bulting the phonetisaurus model:

pi@raspberrypi:~ $ nano  phonetisaurus.sh
pi@raspberrypi:~ $ cat phonetisaurus.sh 
#!/bin/bash
sudo su -c "echo 'deb http://ftp.debian.org/debian experimental main contrib non-free' > /etc/apt/sources.list.d/experimental.list"
sudo apt-get update
sudo apt-get -t experimental install phonetisaurus m2m-aligner mitlm libfst-tools

#-untar libraries source code

tar -xvf m2m-aligner-1.2.tar.gz
tar -xvf openfst-1.3.4.tar.gz
tar -xvf is2013-conversion.tgz
tar -xvf mitlm_0.4.1.tar.gz

#build libraries source code
cd openfst-1.3.4/
sudo ./configure --enable-compact-fsts --enable-const-fsts --enable-far --enable-lookahead-fsts --enable-pdt
sudo make install # come back after a really long time
cd ..
cd m2m-aligner-1.2/
sudo make
cd ..
cd mitlm-0.4.1/
sudo ./configure
sudo make install
cd ..
cd is2013-conversion/phonetisaurus/src
sudo make
cd ../../../
sudo cp ~/m2m-aligner-1.2/m2m-aligner /usr/local/bin/m2m-aligner
sudo cp ~/is2013-conversion/bin/phonetisaurus-g2p /usr/local/bin/phonetisaurus-g2p
wget https://www.dropbox.com/s/kfht75czdwucni1/g014b2b.tgz
tar -xvf g014b2b.tgz
cd g014b2b/
./compile-fst.sh
cd ..
mv ~/g014b2b ~/phonetisaurus
reboot

running jasper.py will not complain anymore about the params that you have configured in .yaml but not build in he environment

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.