1

First off, I'd like to state that I'm not a complete noob when it comes to Linux, in general. I just haven't worked with it as my primary OS and my interaction with it has been on and off so I'm a little rusty on a few things.

I've setup a new backup drive through my Windows 10 pro server (usb3.0 drive) and I've setup an SFTP server on my Raspberry pi 2 which I plan on using to have my remote locations come in to run backups to the drive attached to the Windows 10 server's attached drive.

I tested everything out initially using mountpoints pointing to a WD Mybook NAS drive and everything worked without issue (except it would not work when put into fstab... I'll explain more about this later). Basically, I'm putting the mount point for the sftp user in their home folder so that the FTP client has direct access to it.

I've referenced Connect Raspberry Pi2 to Windows 10 Shared folder to confirm what I'm doing should work but I keep getting an access denied error when I change the mountpoint from the NAS drive to the Windows 10 server.

Test information: Username: pibackup Password: rpi2 Windows 10 server: 192.168.5.11

command: mount -t cifs -o username=pibackup,password=rpi2,iocharset=utf8,sec=ntlm,uid=sftpusr //192.168.5.11/Music /home/sftpusr/music

Returns: mount error(13): Permission denied Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

Now, when I used that same exact command pointed to my NAS drive (192.168.5.5), it worked just fine. The only issue I had with the NAS drive mount command (which I do not want... I need it to point to the Windows 10 server) was when I added the listing to fstab, I got that same exact error I'm getting when I'm trying to use the mount command to point it to my W10 box.

I have no idea why I cannot mount this share. I have verified that the share, username, and password all works via 2 other computers on the network.

Any thoughts?

  • your mount command looks a lot like mine, and mine works (I've added vers=3.0 option because I've disabled SMB1 on windows - but you'd get a mount error(112): Host is down in that case) Of course, you have windows 10 pro server I have just windows 10 pro. However, I still suspect that the issue is on the windows 10 machine (i.e. the user pibackup or the users access to the share you've setup), not with your mount command – Jaromanda X Aug 20 '17 at 0:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.