3

So, I have a RetroPie running on Pi-3B, with the RemotePie HAT controlling on/off.

When I turn it on, unless my TV (1080p HD) and HDMI switch are set to the inputs to display the Pie, the display is stretched and displays too big (I can't see the bottom options in Emulationstation.)

Is there any way to force the resolution to whatever it is when the display is correct?

I use a Harmony remote to turn everything on and set input, and my HDMI switch doesn't allow me to change to an input that currently doesn't have signal.

1 Answer 1

1

The settings is done in config.txt, the documentation for all options is found here: https://www.raspberrypi.org/documentation/configuration/config-txt/

3
  • Is there a way to see what options it's using now and hardcode them into the config.txt? I see dozens of combinations I could use as a trial/error method, but that would take so long.
    – Josh B
    Aug 23, 2017 at 13:57
  • I'm not sure about RetroPi. It could be "fbset -s".
    – MatsK
    Aug 23, 2017 at 15:20
  • Sorry this is a bit old, but was wondering if this would mean anything. I don't understand all the options... Would it be Group 1, option 34 then, which is 1080p 30Hz? pi@retropie:~ $ fbset -s mode "1824x984" geometry 1824 984 1824 984 32 timings 0 0 0 0 0 0 0 rgba 8/16,8/8,8/0,8/24 endmode
    – Josh B
    Mar 22, 2018 at 19:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.