TL;DR My Raspberry Pi (Model B+) can't run the newest Raspbian (Stretch), suspected is that the kernel doesn't work. Anything with a kernel version above 4.1.19 will fail to load. Does this mean that this model is at the end of it's life or does this only happens to me?

Yesterday I did something stupid, I thought I could easily update my PHP version on my Raspberry. Now, in the basics it should be easy but I couldn't get it to work, somewhere it was suggested to update the Pi's software with sudo apt-get upgrade. So I did that and let it be for the time being.

I went to lunch and came back to find out it crashed my Raspbian and I was unable to access it properly. To get the files back it was suggested to get another SD-card and install a new version of Raspbian (Stretch). Get a USB memory card reader and plug it into the Pi to copy my data. The idea seemed fine and it worked eventually but I could not get the Pi booted with Stretch as it turns out. The Pi showed an multi-color (rainbow) square and couldn't get passed it, tried several SD cards and none worked. I also tried NOOBS but that didn't work either.

I was suspecting that the newer Raspbian version could be a problem so I searched for a older version (Jessie, Lite). When I found the links for the Jessie versions, I tried a couple of them but some of them failed as well. I think that the problem that causes the rainbow square was most likely, the kernel version because every image with a kernel version higher than 4.1.* will fail to load but when I booted a image with kernel 4.1.19 it worked.

Now I got my Raspberry Pi back to normal but with outdated software, the apt repository seems to be outdated as well since I only get older versions of packages. I'm afraid to update the Pi again since it most likely will fail again and renders my Pi useless. With that in my mind it seems to be that my Raspberry Pi (Model b+) is at the end of it's life. What do you guys think? Are there other people with the same issues as I or are there any suggestions?

  • I just download the Raspbian Stretch release image, and create a new SD card, and plug it into my 4-year old Raspberry Pi model B+, and I can confirmed that it is works. So Raspberry Pi model B+ has not come to the end of life. There must be something wrong happened during your upgrade. I would suggest that you to create a new SD Card with Raspbian Stretch and try it out if you are so afraid that upgrade will screw up your existing configuration.
    – hcheung
    Commented Aug 23, 2017 at 6:57

3 Answers 3


The rainbow square is an under-voltage warning. You might consider upgrading to a more powerful power supply (more amps, not more volts).


To further answer your question I have tried to reproduce your issue. I have installed a new sd card with Raspbian Stretch and inserted in a B+. It boots normally and has been running ever since. Also after reboots.

The model 1 B+ is not end of life.


While the blog post about the latest release on raspberrypi.org don't clearly state it, one of the devs did confirm in a comment on that blog post that it supports Pi 1 and 0.

You can find it here: https://www.raspberrypi.org/blog/raspbian-stretch/#comment-1328377

The comment from Simon Long states:

...we are not about to orphan Pi 1 and Pi 0, and managing multiple versions of the OS is a headache and will lead to numerous user issues, from people trying to run the 64-bit version on early platforms...

in response to community members asking for a 64bit version of Raspbian.

  • Add the gist of whats the context of the url you refere to.
    – MatsK
    Commented Oct 9, 2017 at 14:42

Ok, so I'm a few months further and I can confirm that the model has not reached it's end of life. A few weeks back I was able to install the latest version of Stretch on the PI and it works.

Somehow it wasn't working back then, I really don't know what it was. Nothing changed since then other than a new download of Stretch.

Not the answer you're looking for? Browse other questions tagged or ask your own question.