I have a Pi 3B that until today was working fine on the local network, it has a fixed IP address, e.g., and I can ping it, and I can ssh from that Pi to any other device on the network. But ssh the opposite way is not working any longer, nor is UDP which I use for OSC communication. I have several identically configured Pis, they all behave well. That particular machine was working fine all the time, and I didn't change anything to the configuration.

What could cause this? ping works fine, but ssh -vvv [email protected] simply says

OpenSSH_7.4p1 Debian-10+deb9u1, OpenSSL 1.0.2l  25 May 2017
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug2: resolving "" port 22
debug2: ssh_connect_direct: needpriv 0
debug1: Connecting to [] port 22.
debug1: connect to address port 22: Connection refused
ssh: connect to host port 22: Connection refused

and Open Sound Control messages via UDP simply don't arrive any longer. sudo service ssh status says ssh daemon is active and listening on port 22 ( ifconfig confirms the IP address is set as I thought. I have no idea what's wrong now. My only idea now is to duplicate the SD image from one of the other Pis. But sure there must be an explanation.

  • Did you upgrade the OS on your Pi recently? I know that SSH is disabled by default now on Raspbian. Perhaps one or more of the new default settings are causing your issues. Commented Aug 22, 2017 at 21:00
  • No, I didn't, and I verified that ssh is enabled
    – 0__
    Commented Aug 22, 2017 at 22:28
  • Which distro do you have installed? Commented Aug 23, 2017 at 15:47
  • Raspbian Jessie
    – 0__
    Commented Aug 25, 2017 at 0:18

1 Answer 1


Since the outward going traffic was all working, I started to suspect that the problem might have not been the Pi but my laptop. So it turned out, I could use ssh from another Pi to this particular Pi without problem, confirming that it was a problem with the ssh client on my laptop that for some unknown reason could not connect to that particular IP (although it had no problem with others). After a while, magically all was working fine again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.