2

I tried to install Alexa Voice Service on my Raspberry Pi 3 by following these instructions:https://github.com/alexa/alexa-avs-sample-app/wiki/Raspberry-Pi.

On step seven (terminal window 2) when I run the command:

cd javaclient && mvn exec:exec

I get the error

The error was "Unable to load library 'vlc': Native library

followed by a huge path. I also tried running the command as :

mvn exec:exec "-Dalpn-boot.version=8.1.6.v20151105"

but that also yielded the same error. How can I resolve this?

  • My Java version is: java version "1.8.0_65" Java(TM) SE Runtime Environment (build 1.8.0_65-b17) Java HotSpot(TM) Client VM (build 25.65-b01, mixed mode) – Saarthak Gupta Aug 23 '17 at 7:03
  • I am having the exact same issue and tried to install the VLC library but it just said I already have the latest version. Any other idea? – Dennis Wenger Aug 30 '17 at 22:43
1

Install VLC Library

It's probably trying to use the VLC library, but it's not installed.

To Install: sudo apt-get install libvlc5

| improve this answer | |
0

Installing the dev version fixed the problem for me.

sudo apt install libvlc-dev
| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.