1

I installed OSMC on my Raspberry Pi as a home media center. However whenever I boot up my Raspberry Pi, it will turn my TV on automatically.

Is there a way to disable this behaviour through some configuration?

| improve this question | | | | |
1

Assuming you're using an HDMI connection, the power on signal is probably sent using CEC, which is a feature of HDMI.

To disable CEC in OSMC, you'll need to SSH into your Pi, then open /boot/config.txt. Here's how to do it with the nano editor:

sudo nano /boot/config.txt

Then, add the following line (or, if the hdmi_ignore_cec is present and set to 0, set it to 1):

hdmi_ignore_cec=1

Note that you'll lose all power on ability from the Pi by doing this. Once you've set that, press Ctrl + O to save and Ctrl + X to exit.

Reboot your Pi, and test if the issue is resolved. If not, it's likely to be a setting on your TV which switches it on when an input changes. Consult your TV documentation if that's the case.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.