2

Fresh install of NOOBS 2_4_3 Stretch using http://goddess-gate.com for repository mirror. Here is what I'm getting:

    sudo apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
  chromium-browser libbluray1 lxpanel lxpanel-data pi-bluetooth python3-jedi 
rc-gui
7 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 59.9 MB of archives.
After this operation, 30.7 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Err:1 http://archive.raspberrypi.org/debian stretch/main armhf chromium-
browser armhf 60.0.3112.89-0ubuntu0.14.04.1.1010
  500  No space left on device [IP: 93.93.128.211 80]

E: Unable to fetch some archives, maybe run apt-get update or try with --
fix-missing?
...

df -h gives:

Filesystem      Size  Used Avail Use% Mounted on
/dev/root        13G  4.1G  8.1G  34% /
devtmpfs        426M     0  426M   0% /dev
tmpfs           430M     0  430M   0% /dev/shm
tmpfs           430M   12M  419M   3% /run
tmpfs           5.0M  4.0K  5.0M   1% /run/lock
tmpfs           430M     0  430M   0% /sys/fs/cgroup
/dev/mmcblk0p6   68M   21M   47M  31% /boot
tmpfs            86M     0   86M   0% /run/user/1000
/dev/mmcblk0p5   30M  398K   28M   2% /media/pi/SETTINGS

df -ih:

pi@raspberrypi:~ $ df -ih
Filesystem     Inodes IUsed IFree IUse% Mounted on
/dev/root        845K  139K  706K   17% /
devtmpfs         107K   369  107K    1% /dev
tmpfs            108K     1  108K    1% /dev/shm
tmpfs            108K   446  108K    1% /run
tmpfs            108K     3  108K    1% /run/lock
tmpfs            108K    10  108K    1% /sys/fs/cgroup
/dev/mmcblk0p6      0     0     0     - /boot
tmpfs            108K    17  108K    1% /run/user/1000
/dev/mmcblk0p5   8.0K    14  8.0K    1% /media/pi/SETTINGS

... sources.list

 cat /etc/apt/sources.list
# *********************************************************************
# ****                       original                             *****
# *********************************************************************
# deb http://mirrordirector.raspbian.org/raspbian/ stretch main contrib non-
free rpi
# *********************************************************************
# *********************************************************************
# Uncomment line below then 'apt-get update' to enable 'apt-get source'
#deb-src http://archive.raspbian.org/raspbian/ stretch main contrib non-free 
rpi
#deb http://mirror.ox.ac.uk/sites/archive.raspbian.org/archive/raspbian 
stretch main contrib non-free rpi
#deb http://raspbian.ufms.br/raspbian stretch main contrib non-free rpi
deb http://goddess-gate.com/archive.raspbian.org/raspbian stretch main 
contrib non-free rpi

This is the third mirror that I'm seeing this on. I started with the default mirror director. It gave me the 500 error. After a day of searching the web, I decided to try a different mirror and managed to update and install an app. I've tried going back to Noobs 2_4_2 Jessie, but the problem followed. I've tried switching micro-SD cards with no luck. My question is multi-part. What does that error really mean? If it is my problem how do I fix it? Does any one have a non-mirror-director mirror that they can verify is not returning this error?

  • Have you tried the sugested solution: sudo apt-get -- fix-missing – MatsK Aug 24 '17 at 17:05
  • Yes, thanks for the suggestion though. – Joel-Brooks Aug 24 '17 at 17:21
  • @Joel-Brooks what is the output of df -ih ? – alexy13 Aug 24 '17 at 19:22
1

I decided to drill down into this problem to see where exactly the problem is. I found it. Good news for almost the rest of the community; this isn't a Raspberry Pi problem. Bad news is that for me at least, it is a Sophos problem. Sophos is an enterprise level firewall/web filtering piece of... hardware. The way that I determined the root of this problem was to first try to browse through a repository with chromium. I got to the point of opening the Package list when Sophos presented an error of "No space left on device" I then tried to

wget http://mirror.us.leaseweb.net/raspbian/raspbian/dists/stretch/main/debian-installer/binary-armhf/Packages

the package list and got the 500 alarm with the same error. I think that I might be able to do a `apt-get --just-print upgrade' as suggested on the Unix and Linux Stack Exchang site here. Sophos is beyond my control and beyond the scope of this site. I'll have IT fix it.

Thanks to all that took time to assist.

  • I never thought we'd have to ask a Raspberry Pi user to disable their Anti-Virus while troubleshooting! :P – Hydraxan14 Aug 25 '17 at 16:34
  • Lol true @Hydraxan14 – Joel-Brooks Aug 25 '17 at 17:32
0

I also had this error. I just ran sudo apt-get dist-upgrade and that seems to have fixed my error.

  • Good suggestion, but it didn't work for me. I got the same results. – Joel-Brooks Aug 24 '17 at 19:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.