When I ssh into it, it instantly drops the connection. When I hook it up to the monitor it accepts my login, shows the last login time (about 30 seconds before this attempt) the kernel version, the copyright, and warranty information, and then it instantly dumps me back to the login prompt. I've tried power cycling the pi and I get the same response.

  • Is the Pi kicking you out, or is your network connection dropping? You can get this if your wifi signal is weak and many packets get dropped. That could be wifi to your Pi or wifi to the machine from which you initiate the ssh.
    – Brick
    Commented Aug 29, 2017 at 12:36
  • 1
    The pi kicks me out. When I log in locally it logs in, shows the last successful log in time, kernel version, etc... and then goes straight back to a login prompt
    – Naosuke84
    Commented Aug 29, 2017 at 22:49
  • Try running "ssh <RPi> /bin/bash". If that gives you a shell prompt, then there's something wrong with your login environment. Try renaming likely dot files (e.g. .login , .bashrc, .bash_profile, .profile) and try logging in again. Commented Jan 22, 2019 at 22:09
  • I can't comment due to insufficient reputation, however I have the same issue. Is your Pi overclocked?
    – ProDigit
    Commented Aug 31, 2019 at 7:18

2 Answers 2


Try re imaging your sd card and the problem still persists try changing the sd card. Otherwise check if the pi is getting extremely warm.

  • It doesn't seem very warm, but I was trying to avoid having to rebuild. This pi is my unity controller.
    – Naosuke84
    Commented Aug 26, 2017 at 14:02
  • You could always copy the files off the sd card.... Commented Aug 26, 2017 at 14:57

Is ssh enabled on your pi? You may have to enable it in the raspberry pi configuration or raspi-config. If it is enabled, then do you have a firewall running on your pi? Sometimes firewalls on raspberry pi's will disable ssh. If you turn off the firewall temporarily then the problem may be solved. Hope that helps you. :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.