1

Now, here is my question:

Who hates apt-get? Almost no one. Who gets problems with apt-get? I do. And I am.

Sometimes, using sudo apt-get upgrade takes sooooo long you just close off terminal to stop the "upgrade".

Oh well. Tried that, and now I'm getting problems when trying to install something else. For example, sudo apt-get update or sudo apt-get mesa-utils(A graphics library) didn't work. sudo apt-get upgrade didn't work at all, either, when I tried to try the upgrade again. I even went to the Raspberry Pi config (sudo raspi-config) and tried the update thing there (advanced options -> update), but they all outputted this or similar error messages.

E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?

And yes, these errors popped up right after or during update/upgrade/installing time, and, as you can see, I was using the sudo's right.

What do these errors mean? How can they be fixed? And if you say I have to reinstall Raspbian all over again, weeeeell. Yeah.

Thank you.

0

Well the upgrade process still has locked the applications and the process might still be running in the background or glitched, try rebooting and then install a new version of raspbian, might save the update time.

  • Thanks Enan. Reinstalling Raspbian solved all my problems, though I have to criticize you for making me lose all my data. Anyway, I'm way more gratefull than I am mad. – iostreamerX Aug 27 '17 at 1:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.