0

I am faced with an apparent time consuming problem or something else when I try to install scipy with pip for python3.6 on my RPi2 model B. OS is Raspbian minimal (jessie).

I am using a RPi2, and I successfully managed to follow the suggested procedure to install python3.6. But as pointed out by a commenter, I ran into problems with ssl when I tried to install packages with pip.

I learned from another thread on different subject that I need to install ssl before I compile.

sudo apt-get install libssl-dev
wget https://www.python.org/ftp/python/3.6.0/Python-3.6.0.tgz
tar xzvf Python-3.6.0.tgz
cd Python-3.6.0/
./configure
make
sudo make install
python3.6 -V
python3.6 -m pip install --upgrade pip
python3.6 -m pip install --user numpy 
sudo apt-get update
sudo apt-get upgrade

I first ran into an error while installing scipy, but got past that with the sugested libatlas-base-dev gfortan requirement.

sudo apt-get install libatlas-base-dev gfortran

python3.6 -m pip install --user scipy

the installation of scipy with pip takes a very long time (hours) and I am looking for a solution. I'll get back to this. the rest of the installation is now put on hold.

python3.6 -m pip install --user matplotlib

python3.6 -m pip install --user ipython

python3.6 -m pip install --user jupyter

python3.6 -m pip install --user pandas

python3.6 -m pip install --user sympy

python3.6 -m pip install --user nose

The upside of having to compile python3.6 a second time was a much faster compile the second time. On the other hand it takes a long time to install numpy, and that is why i split up the package installation. But it takes such a long time to install scipy that I am thinking there is another problem.

After hours of waiting for scipy to install, the green light on my PI has a constant green light (no blinking). I tried to open up another tty, but I can't log in there. So i got back to the tty with the installation script and hit ctrl+c to exit. I rebooted and I'm giving it another try.

But after waiting for another 7 hours I have the same situation. The constant green light on my PI, and no respons on tty2. I ctrl+c to exit.

  • I will look into this solution to make a Jupyter Notebook Server on Raspberry Pi 2. – vardaasen Aug 27 '17 at 11:27
  • Have you considered installing the compiled package from the Raspbian repo? sudo apt-get install python3-scipy – Aurora0001 Aug 27 '17 at 12:37
  • well the python3 preinstalled with jessie is python3.4, what will i get when I sudo apt-get install python3-scipy? After installing python3.6 I have python2.7, python3.4, and python3.6 on my pi-2 – vardaasen Aug 27 '17 at 18:36
  • for good measure I did sudo apt-get install python3-scipy. But scipy does not show up in python3.6 modules | less or python3 modules | less although dpkg -l python3-scipyshow it is installed. – vardaasen Aug 27 '17 at 22:36
0

I had the install also failing once with a constantly lit green LED. Then I noticed a quite warm cooling bridge in my Pi-top and I've cooled it with my fingers and suddenly the compile process went faster. I can't tell the total time but the green LED is now regularly blinking. I noticed that the RPi slows down quickly when the CPU is over 50...60 deg C. I will buy an USB fan to produce an airstream or maybe place the case vertically to increase convection cooling.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.