3

My Pi is not starting up. None of the lights go on. I've searched online for similar problems but couldn't find anything.

HOW IT HAPPENED:

I was controlling my Pi with my laptop using PuTTY. Then I wanted to connect my screen to the Pi so I disconnected the power, connected the HDMI cable and reconnected the power and then nothing happened after that. Thing stays dead. I did notice that when I connect the power the power LED gives a very short blink, but nothing else.

TRIED THE FOLLOWING:

  1. Three different power adapters. They all charge my cellphone. One is 1 A and other two were 700 mA.

  2. Tried re-imaging my SD card.

  3. Tried a different SD card.

  4. I left the Pi for more than 12 hours without power.

Nothing seems broken on the board. I really don't know what to do.

Any suggestions? Any idea what I did, or am doing, wrong?

3

It does unfortunately sound like your Raspberry Pi is broken. I would recommend that you contact the vendor to see if it is covered by the warranty so that you can get it replaced.

I had a similar issue with mine where it would power on, but it would not display a picture. It is unfortunately not something that you can easily troubleshoot yourself, as all the components are soldered onto the board.

  • Yes seems so. Getting it replaced – Jeandre Pentz Apr 28 '13 at 17:36
2

In my case I was using one Pi Zero W for around 4-5 months and then I didn't use it for few weeks. And then when I plugged it back it didn't came up.

My first guess was it was broken, because the indicator LED was not blinking.

But after googling for some time I realized this can happen for some other reasons as well.

Finally I came across this question and came across @Frank's answer which pushed me to go back and check the micro SD card. Then I realized there was an issue with SD card partitions.

Recreate the SD card, WOW.... That's it. My Pi Zero is back up with the blinking green light :)

1

I have something very similar happening, except I don't even get the slight flash of the power led.

If you are getting some suggestion of power you may want to check that your USB power supply is supplying sufficient voltage. I've seen reports of some power supplies down in the 4.5-4.7 volt range and this may not be sufficient to power up your PI.

1

I realize I'm way late to the party, but were you able to power later Pis?

I had a similar problem, and it looks like it was a power supply issue. My power supply was 5V 1.5A supply, similar to yours. But I tried it with a 5V 2A supply, and it sprang to life.

I decided to try the bigger power supply after finding this in a product description on Adafruit:

This adapter was specifically designed to provide 5.1V not 5V, but we still call it a 5V USB adapter. We did this on purpose to solve a problem that occurs often with USB-powered gadgets: they draw so much current than the resistance of the cable causes a voltage drop, so instead of 5V, the device sees 4.75V or so. To avoid this problem, we made the adapter 5.1V and the USB cable has extra-beefy 20AWG wires! This way, even at a full 2 Amp draw, the voltage at the end wont be lower than 4.9V

I haven't ordered their part, but the reasoning sounds good enough to test out a bigger power supply for your Pi.

  • Hi, I think this will help some people with their problem, but not in my case. I did get a new pi and tested with the same powersupply and everything worked fine. Plugged back in the old one, still dead. So in my case it was that my pi was just dead. – Jeandre Pentz Feb 17 '15 at 5:47
  • I'm glad you got a better model. Cheers! – Chris May Feb 18 '15 at 14:44
1

I'll make an educated guess that /dev/sX1 had the dirty bit set, when the power was pulled.

Do a fsck -y /dev/sdX1 and probably you're good to go.

1

I had the same issue, I was powering my Raspberry from a wall socket + adapter that I also use to charge my phone.

It worked for about 6-7 months then for some reason I had the exact thing you described.

I have found two solutions, though the exact underlying reason is still somewhat a mystery to me:

  1. Using a powerbank that I used to charge my phone instead of wall socket fixed it. Yet that wasn't the kind of a solution I was looking for.

  2. Then I replaced the cable that connected adapter to the raspberry, and for some reason then I was able to power raspberry from socket as well.

My guess is that my cable was worn out in time, so its resistance increased. That is why I had to have either a better regulated supply (better than the adapter I used), or a connecter with less resistance.

Since you have already tried different and it has been discussed above, I would recommend changing the cable you use to connect Raspberry with the power supply, in case you haven't. Although it seems unlikely, it was the problem in my case.

1

One thing to double check is the SD card. I bought few at "low cost". In theory class 10.

Started the first 2 RPI zero W, and it worked for a few hours. Then I started to have issues: not even the LED. I thought about everything, USB cables, power, etc... This also for a couple of RPIs.

But at the end was the SD cards, all not working. I just tested with a single better quality more expensive SD card and all was fine.

What made me thinking was an hardware issue was that at first it was working (for even 2 boards), and I could read the SD cards on my PC.

The problem might even be a combination of factors. I suggest to keep around at least 1 set of good quality material: SD, USB cable, power supply, etc. That in such a case, you do not need to waste a board.

One link that was helpful: https://www.raspberrypi.org/forums/viewtopic.php?t=204535

0

I just ran into this too. Turned out to be a short circuit. When I mounted the hardware one wire was touching the metal frame. Check to see if the Pi is warm near the power supply.

After putting some electrical tape between the wire and frame it boots up again.

protected by Community Dec 30 '18 at 9:12

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.