4

Backstory

My Raspberry Pi is a version 2 Model B. For my company, we always use this model with the same SD card images for years now. Recently we bought new Pis from a different company, the same model. We've tried two Pis with two different SDs that work in Pis from other companies.

The Linux flavour is Raspbian and the kernel version is 3.18.11-v7+.

Question

When the Pi boots the red light comes on and stays solid. But the green light links blinks 4 times long and 4 times short. Is that supposed to be a total of 8 blinks or two variations of 4 blinks?

  • What OS? What version of kernel? – Milliways Aug 29 '17 at 0:17
4

MatsK answer was quite helpful. The link tells me that 8 flashes is "SDRAM not recognised." This was actually what the problem was. I was using an older loader on a newer Pi. It seems that there is more than one version of a Raspberry Pi 2 Model B. Previously, we were using version Raspberry Pi 2 Model B v1.1 with our image. Recently, we've been getting Raspberry Pi 2 Model B v1.2 boards. These newer boards do NOT like the older image.

To fix it, I just used a newer version of Raspian. I tried upgrading the old image, but it caused way too many problems.

So to be that guy and answer my own question, the four long and four short flashes were a total of 8 flashes and not 4.

References

https://github.com/debian-pi/raspbian-ua-netinst/issues/415

https://www.raspberrypi.org/forums/viewtopic.php?t=52683&p=404379

2

There is an excellent page about the boot sequence.

Quote:

According to this forum post the green light will blink in a specific pattern to indicate some types of errors:

3 flashes: loader.bin not found
4 flashes: loader.bin not launched
5 flashes: start.elf not found
6 flashes: start.elf not launched
7 flashes: kernel.img not found

Firmware since 20th October 2012 no longer requires loader.bin, and the flashes mean:

3 flashes: start.elf not found
4 flashes: start.elf not launched
7 flashes: kernel.img not found
8 flashes: SDRAM not recognised. You need newer bootcode.bin/start.elf firmware.

If start.elf won't launch, it may be corrupt.

Note that 4-flashes may point to a defective SD-card holder, if one or more of the data contacts is intermittent it can lead to this problem.

Reference:

http://elinux.org/R-Pi_Troubleshooting#Normal_LED_status

  • OK, I read it and there is no combinations from my knowledge that is 4 long and then 4 short. So I would check the SD card holder or check the filesystem on the SD card as the 4 flashes recommend. – MatsK Aug 28 '17 at 19:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.